I use Raspberry Pi 4 (4 GB RAM) and Raspbian GNU/Linux 10 (buster). I'm would like to run some python programs to capture some data 24/7. Raspberry pi would act as the data collector and another machine would analyze/process the data. My preferred way to store the data and later process on another machine would be: parquet file format

To install pyarrow on the raspberry pi for python3:

pip3 install pyarrow

I get the message:

Failed building wheel for pyarrow
  Running setup.py clean for pyarrow
   Failed to build pyarrow
    Installing collected packages: pyarrow
      Running setup.py install for pyarrow ... error

Command "/usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-install-0d4i0qjw/pyarrow/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-record-dn2pfxo3/install-record.txt --single-version-externally-managed --compile --user --prefix=" failed with error code 1 in /tmp/pip-install-0d4i0qjw/pyarrow/

Afterwards I tried to follow the advice [https://raspberrypi.stackexchange.com/questions/110958/error-in-pyarrow-while-installing-apache-beam-in-raspberry-pi][1]

When running "make" I get the following error:

In file included from /home/pi/pyarrow/arrow/cpp/src/arrow/util/basic_decimal.cc:31:
/home/pi/pyarrow/arrow/cpp/src/arrow/util/int128_internal.h:26:10: fatal error: boost/multiprecision/cpp_int.hpp: No such file or directory
 #include <boost/multiprecision/cpp_int.hpp>
compilation terminated.

Does someone could advice or help how to install pyarrow on the raspberry pi to be able to be used with python?

Thank you

  • Going by piwheels.org/project/pyarrow its never made it on a Pi ! Looking at pypi.org/project/pyarrow and arrow.apache.org/install both use pip not pip3 The latter has a long list of steps under Debian for the C package - not sure if running those first would bring the header file in for you.
    – user115418
    Nov 26 '20 at 10:25
  • @Andyroo thank you for your answer. At least it confirms, that I was not doing something wrong. Do you know, if there are plans that pyarrow will be available for raspberry pi in the future? For now I guess I need to use one of the alternative formats available for a dataframe (like csv or hdf)..
    – Eric
    Nov 26 '20 at 18:52

OS: Ubuntu 20.04

I was able to install pyarrow using this command, on a Rpi4 (8gb ram, not sure if tech specs help):


Found this on a Jira ticket.

Have only verified the installation with python3 -c "import pyarrow" and yet to use the package in some code. Will report back if I see any problems further on.

  • Confirmed on Ubuntu 20.04 on Pi4 - thank you! (Note: I wasn't able to get this work on Buster on a different Pi4)
    – James_SO
    Sep 12 at 15:23
  • @James_SO forgot to add that. I have tried it on an Ubuntu image only.
    – fixxxer
    Sep 12 at 18:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.