1

My system

Distributor ID: Ubuntu
Description:    Ubuntu 20.04.1 LTS
Release:    20.04
Codename:   focal
Raspberry: Raspberry 4B
Raspberry Camera: V2.1

$ uname -a:

Linux ubuntu 5.4.0-1022-raspi #25-Ubuntu SMP PREEMPT Thu Oct 15 13:31:49 UTC 2020 aarch64 aarch64 aarch64 GNU/Linux

$ sudo rpi-eeprom-update:

BCM2711 detected
Dedicated VL805 EEPROM detected
BOOTLOADER: up-to-date
CURRENT: Thu 03 Sep 2020 12:11:43 PM UTC (1599135103)
 LATEST: Thu 03 Sep 2020 12:11:43 PM UTC (1599135103)
 FW DIR: /lib/firmware/raspberrypi/bootloader/critical
VL805: up-to-date
CURRENT: 000138a1
 LATEST: 000138a1

$ vcgencmd get_camera:

supported=0 detected=0

$ groups ubuntu:

ubuntu : ubuntu adm dialout cdrom floppy sudo audio dip video plugdev netdev lxd i2c gpio spi

Last line of $ sudo rpi-update is *** Your firmware is already up to date

The problem

When I run raspistill -o test.jpg I get

mmal: Cannot read camera info, keeping the defaults for OV5647
mmal: mmal_vc_component_create: failed to create component 'vc.ril.camera' (1:ENOMEM)
mmal: mmal_component_create_core: could not create component 'vc.ril.camera' (1)
mmal: Failed to create camera component
mmal: main: Failed to create camera component
mmal: Camera is not enabled in this build. Try running "sudo raspi-config" and ensure that "camera" has been enabled

I then run sudo raspi-config and enable the camera interface. Reboot try again but same error.

What I've done

I followed the prompts by Cerin in this post.

/boot/config.txt contains

dtparam=spi=on
dtparam=i2c_arm=on
start_x=1
gpu_mem=128

For good measure my /boot/firmware/usercfg.txt contains

start_x=1
gpu_mem=128

/etc/udev/rules.d/10-vchiq-permissions.rules does not exist on my system so in sudo nano /etc/udev/rules.d/local.rules I included

SUBSYSTEM=="vchiq", GROUP="video", MODE="0660"

Then in the command line $ sudo usermod -aG video ubuntu

Finally I double checked the physical connection. Set up of the camera looks no different to here

Desired outcome I want to take images with the camera using ```raspistill``. Please lend me your help!!!

2

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.