1

The situation

I have a USB-C Samsung external drive. I bought a USB-A adapter adapter for it so that I can plug it into my new Raspberry Pi 4. It is running Raspbian OS with the latest updates. My Pi is connected via wired connection.

What happens

As soon as I plug the external drive into the Pi, my Pi loses its network connection.

  • I can't SSH to it
  • My Router doesn't have it in its DHCP table

What I've Tried

  • I have tried plugging in the drive multiple times.
  • I have tried rebooting the Pi.
  • I have tried plugging the drive into a different port.
9
  • 2
    Does your Pi4 have enough juice to run?
    – Reishin
    Nov 28 '20 at 19:35
  • 2
    Are you sure that it just loses the network connection, or does it shutdown?
    – goldilocks
    Nov 28 '20 at 19:44
  • 2
    And what about the logs? Nov 28 '20 at 20:51
  • 2
    Does the drive work in another computer?
    – user115418
    Nov 29 '20 at 0:39
  • 1
    Please create an answer for the solution and mark it as the accepted one after two days with a click on the tick on its left side. That prevents your Question from being shown as an unsolved Post to the community and saves them/us a lot of work.
    – Ingo
    Nov 29 '20 at 2:45
1

The cause of problem as solved by @Reishin and @goldilocks was that the Pi didn't have enough power for itself and the drive. The solution to the problem is to connect the Pi to its own adapter. It was previously plugged into my router.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.