0

I need to use full UART. I was using dtoverlay=pi3-miniuart-bt to achieve this but the name suggests it's for pi3, I have pi4. Should I use miniuart-bt instead, or disable-bt as I would want to turn Bluetooth off anyway? On the raspi website there is said:

miniuart-bt switches the Bluetooth function to use the mini UART, and makes the first PL011 (UART0) the primary UART. [...] You must also set the VPU core clock to a fixed frequency using either force_turbo=1 or core_freq=250.

but later I've found this:

Changing core_freq in config.txt is not supported on the Pi 4, any change from the default will almost certainly cause a failure to boot.

It is recommended when overclocking to use the individual frequency settings (isp_freq, v3d_freq etc) rather than gpu_freq, as since it attempts to set core_freq (which cannot be changed on the Pi 4), it is not likely to have the desired effect.

So... what "individual frequency setting" will change "VPU clock" (there is no "vpu" word anywhere on the overclocking page)? Should I just go with enable_turbo=1? I would prefer to keep frequency default, I don't need 550MHz and it would shorten life expectancy of the device, right?

Does disable-bt solve my problem by itself? In the description there is nothing about clocks here:

disable-bt disables the Bluetooth device and makes the first PL011 (UART0) the primary UART. You must also disable the system service that initialises the modem, so it does not connect to the UART, using sudo systemctl disable hciuart.

0

Read /boot/overlays/README for the up-to-date documentation, rather than old unreferenced posts.

The Pi4 has a totally new peripheral module, and older documentation no longer is relevant.

If it was me, I would leave BT alone and use one of the other 4 fully featured UART.

See Raspberry Pi4 UART

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.