1

The question is similar to this one asked 5 years ago. But the provided answer won't solve my issue.

Problem: irw won't show anything although prior configuratin via irrecord was successful.

Setup

  • Raspberry Pi 2 Model B
  • Buster 10.6 raspberrypi 5.4.72-v7+
  • lircd 0.10.1
  • Receiver GPIO 17

Configuration

/boot/config

dtoverlay=gpio-ir,gpio_pin=17

/etc/lirc/lirc_options.conf

[lircd]
nodaemon        = False
driver          = default
device          = /dev/lirc0
output          = /var/run/lirc/lircd
pidfile         = /var/run/lirc/lircd.pid
plugindir       = /usr/lib/arm-linux-gnueabihf/lirc/plugins
permission      = 666
allow-simulate  = No
repeat-max      = 600

[lircmd]
uinput          = False
nodaemon        = False

/etc/lirc/lircd.conf

include "lircd.conf.d/*.conf"

/etc/lirc/lircd.conf.d/elegoo.lircd.conf

This file was created with irrecord: sudo irrecord -n -d /dev/lirc0 ~/lircd.conf

begin remote

  name  elegoo
  driver devinput
  bits           56
  eps            30
  aeps          100

  one             0     0
  zero            0     0
  pre_data_bits   8
  pre_data       0x23
  gap          99861
  toggle_bit_mask 0x0
  frequency    38000

      begin codes
          KEY_POWER                0x49010000001181
          # ...
          KEY_9                    0x44010000001187
      end codes

end remote

Testing

sudo mode2 --driver default --device /dev/lirc0
Using driver default on device /dev/lirc0
Trying device: /dev/lirc0
Using device: /dev/lirc0
Running as regular user pi
pulse 9053
space 4459
...
space 2212
pulse 607
timeout 125069

Logging

Starting the service with sudo systemctl start lircd

Info: lircd:  Opening log, level: Info
Notice: Version: lircd 0.10.1
Notice: System info: Linux raspberrypi 5.4.72-v7+ #1356 SMP Thu Oct 22 13:56:54 BST 2020 armv7l GNU/Linux
Info: Initial device: /dev/lirc0
Info: [lirc] protocol is enabled
Info: Initial device: /dev/lirc0
Info: [lirc] protocol is enabled
Notice: Options: driver: default
Notice: Options: output: /var/run/lirc/lircd
Notice: Options: nodaemon: 1
Notice: Options: plugindir: /usr/lib/arm-linux-gnueabihf/lirc/plugins
Notice: Options: logfile: syslog
Notice: Options: immediate-init: 0
Notice: Options: permission: 666
Notice: Options: driver-options:
Notice: Options: pidfile: /var/run/lirc/lircd.pid
Notice: Options: listen: 0
Notice: Options: connect: (null)
Notice: Options: userelease: 0
Notice: Options: effective_user: (null)
Notice: Options: release_suffix: _EVUP
Notice: Options: allow_simulate: 0
Notice: Options: repeat_max: 600
Notice: Options: configfile: /etc/lirc/lircd.conf
Notice: Options: dynamic_codes: (null)
Notice: Current driver: default
Notice: Driver API version: 3
Notice: Driver  version: 0.10.0
Notice: Driver  info: See file:///usr/share/doc/lirc/plugindocs/default.html
Info: lircd:  Opening log, level: Info
Warning: Running as root
Info: Using remote: elegoo.
Notice: lircd(default) ready, using /var/run/lirc/lircd

Starting irw:

Notice: accepted new client on /var/run/lirc/lircd
Info: [lirc] protocol is enabled

As you can see I get no warnings or whatsoever. It must be something simple. Please can anybody advice?

1

had the same problem, mode2 testing fine, irw nothing.

the problem: irrecord adds more hex code than necessary, the second hex-row causes errors without any error message

KEY_CHANNELDOWN 0x00FFA25D 0x00000001

after deleting the second row, irw works fine:

KEY_CHANNELDOWN 0x00FFA25D

try deleting

KEY_POWER 0x49010000001181

to

KEY_POWER 0x49010000

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.