3

Just upgraded raspian (December 2020 release) and since then, every 15 seconds a computerized voice says "To install the screen reader press control alt space".

Orca is not installed (I assume that's what it is offering to install, I don't know anything about any of this except what I've seen searching for a solution to this problem).

A search found someone asking the same question a few months ago on the pi forums with no responses at all.

1
  • Looks like one of the engineers on the Pi forum has answered this raspberrypi.org/forums/…. Bill - if this works, can you please answer your own question with how it was fixed / stopped?
    – user115418
    Commented Dec 5, 2020 at 0:13

5 Answers 5

4

If using a headless RPi, do this: ps -eaf | grep wiz

which gives this:

root       583     1  0 14:54 ?        00:00:00 sudo -AE piwiz
root       602   583  0 14:54 ?        00:00:01 piwiz
root      1195   602  0 14:56 ?        00:00:00 sh -c aplay /usr/share/piwiz/srprompt.wav
root      1196  1195  3 14:56 ?        00:00:00 aplay /usr/share/piwiz/srprompt.wav
pi        1199   945  0 14:56 pts/0    00:00:00 grep --color=auto wiz

Then kill the process with pid 602

I don't hear it anymore.

1
  • 1
    I did this but it came back on next reboot. The problem was that the sound freaked me out so much that I didn't finish the setup procedure, when you complete the setup it stops.
    – Bill K
    Commented Dec 21, 2020 at 16:30
4

The suggestion by Andyroo works: for headless raspberry pi, you can remove the file that triggers this on every reboot. Assuming you can ssh into the device or plug a keyboard:

sudo rm /etc/xdg/autostart/piwiz.desktop
1

I also had this problem. Here is some background info I found.

The audio message is a recently added feature to help visually impaired users to install a screen reader. It is part of piwiz which is used to configure the system on the very first boot. The idea is that you only hear the message on a brand new system and it disappears when you move past the first configuration screen. Unfortunately there are some use cases where you can't do that. If your system has no screen and keyboard (ie is headless) then you can't progress beyond this point. The repetitive message makes the sound system completely unusable.

A couple of factors make the situation more problematic. Currently there is very little published information about this feature. And the audio message is so poorly recorded that it is difficult to understand what it is saying. Googling for a solution turns up few results.

There is a question on the Rasperry Pi Forum here.

And an issue was raised on the piwiz github here.

The devs replied that they weren't going to change it and locked the thread to prevent any further discussion.

Possible fixes collected from various other posts.

  1. Rename the wav file so it can't be played (worked for me).
sudo mv /usr/share/piwiz/srprompt.wav /usr/share/piwiz/srprompt.wav.bak
  1. Delete the file that runs piwiz (not tried).
sudo rm -f /etc/xdg/autostart/piwiz.desktop
  1. Use the system as the developers intended. Attach a screen and keyboard and carry out all the steps of the first run configuration. According to the devs you will only hear the audio message on the very first screen. Then it will be gone for good. If you have a headless system you should use a more appropriate version of the OS. ie not a desktop version.

Not a fix Don't follow the instructions in the audio message. This will enable the screen reader as a permanent feature. All the visual information on the screen will then be read aloud, which is probably not what you want.

1
  • My system has a monitor, but no mouse and keyboard. Turns out the monitor has a speaker. Found this out through this message.
    – user242579
    Commented Apr 20, 2021 at 11:58
0

You can always initiate the installation, then run 'orca -s' in a terminal. Go to the 'speech' tab, and there uncheck 'Enable speech'. Now, you have accommodation for visually impaired users but have disabled it for your use. You can do various things and ultimately uninstall Orca, but this was easiest for me and retained the feature's availability.

0

The sound is produced by the initial configuration manager. And I assume you don't use a monitor and don't see it. Therefore it is so mysterious.

For this case, you can disable "Desktop Login". By choosing System Options -> Boot Autologin -> Console.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.