1

I have a setup where I have my pi getting internet from my router on a wifi dongle, and then a blu ray player is connected to the pi's ethernet. The pi should be able to forward packets through from the wireless nic to the wired nic (this works perfectly fine with debian). So my setup looks like this:

internet <---- wlan0 ---> pi <---- eth0 -----> blu ray player

The pi has a static ip to get to the internet, and this works perfectly fine. The problem is, when i give the eth0 interface a static ip on a different subnet, it will only remember this setting for about 40 seconds. Until that time is up, I can ping the pi from the blu ray player, and i can ping the pi from the router/internet side as well. The command to add the static ip for eth0 is:

ip addr add 192.168.0.1/24 dev eth0

also, my router/internet subet is 1.1/24, so eth0 will be on a different subnet from wlan0 (which is what i want).

Another thing to note is taht when I am on the terminal locally on the pi, and the raspbmc gui is not running, the ip settings will not reset themselves every 40 seconds. When the gui is running, they will get reset. I can only assume a deamon is running in the background doing something naughty when the gui is up.

Does anyone know how to stop raspbmc from messing with the network settings entirely? or even to allow for multiple nics to be in use at the same time? I would settle for just stopping raspbmc from resetting my configuration for eth0. I would not like to go to raspian and lose the awesome database stuff raspbmc can do. Thanks in advance

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.