3

I recently updated my Pi4 to the latest version of Raspberry Pi OS, following all the steps to change the audio software to pulseaudio - from the instructions on the website. https://www.raspberrypi.org/blog/new-raspberry-pi-os-release-december-2020/ Upon rebooting I discovered I could no longer listen to audio through either the HDMI or the AV jack. I can only listen to audio now via bluetooth. Has anyone else had this problem or does anyone know how to fix it? Thanks

Edit: I'm now having a similiar problem on a new sd card with ubuntu 20.04. I've tried removing pulseaudio but that hasn't helped. Anyone know how i can fix this?

2
4

Make sure HDMI is selected as default output in Sound & Video -> PulseAudio Volume Control settings. You have to click on the green checkmark with "set as fallback" tooltip in the screenshot below:

enter image description here

If that doesn't help, or you don't want to keep Pulse at all, remove pulseaudio, reboot, and your system should be back to plain ALSA. You can configure ALSA sound from command line with alsamixer.

If you want Pulse back, or didn't get it due to packages being held back, can force the update with sudo apt-get upgrade raspberrypi-ui-mods.

3
  • 1
    That worked perfectly. Thanks!
    – Ben
    Dec 7 '20 at 16:38
  • @Stefano, thanks for confirming it worked for you too. Dec 7 '20 at 17:13
  • Strange, I can't find "PulseAudio Volume Control" in my Pi's Sound & Video menu. The OS is certainly up-to-date and I've installed and upgraded raspberrypi-ui-mods.
    – TD540
    Jan 6 at 7:35
2

In my case the problem was that raspberrypi-ui-mods had been held back and it needed to be force updated. You can confirm this by checking if there is a message about it being held back when you run sudo apt upgrade.

Upgrade raspberrypi-ui-mods by running sudo apt-get upgrade raspberrypi-ui-mods.

If you remove pulseaudio, apart from this not being recommended, it will only end up being installed again when you apt upgrade, so that is pointless.

4
  • I'm pretty sure apt will not reinstall a removed package with an apt upgrade. Dec 17 '20 at 14:18
  • That's what I thought too, but at least on raspberry pi OS it ended up being reinstalled immediately on apt upgrade. Dec 20 '20 at 22:51
  • Are you sure you didn't run other commands in between, which can install additional packages, such as apt dist-upgrade, apt -f install, apt upgrade pkg_name, etc? I must admit I didn't test it though, I personally like Pulse and find it crazy that Pi OS had to wait until 2020 to make use of it. Dec 21 '20 at 8:31
  • Yup, pretty certain. I also was surprised. Dec 22 '20 at 9:43

Not the answer you're looking for? Browse other questions tagged or ask your own question.