I am trying to control mplayer 1.3.0 (Debian) with the mouse. After installing, the input.conf file at ~/.mplayer was missing, so I created one. However, mplayer still does not react to the keybindings in this file.

I copied the keybindings to /etc/mplayer/input.conf and it worked, although not the mouse input. So I tried to reinstall mplayer by deleting the folders ~/.mplayer and /etc/mplayer and running sudo apt-get remove mplayer

Now it is not even reacting to keybindings in /etc/mplayer/input.conf (which was an empty folder, I had to recreate this file) anymore.

How can I get mplayer to react to keyboard and/or mouse input again?? Thank you! :)

Edit: After further investigation, I suspect the problem has to do with the message "Buffer is too small for command pause" which I get after running mplayer. This is the only content of my input.conf files:

g pause

1 Answer 1


sudo apt remove mplayer only removes the program but not its configuration files to preserve them for a new installation. Try to use

rpi ~$ sudo apt purge mplayer
rpi ~$ sudo apt autoremove
rpi ~$ sudo apt update
rpi ~$ sudo apt full-upgrade

That will also remove all configuration and maybe orphaned libraries. Then reboot and install mplayer again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.