1

I just got raspbian installed on my SD card and am trying to get my Pi on my network. It's protected with WPA2 Personal.

I opened up the gui network connect and added a new network with the proper SSID, security and password. However, the Pi won't connect. All I'm getting as the status is "Scanning" and the last message being "WPS-AP-AVAILABLE-AUTH".

  • Are you scanning first, then selecting your network from the scan results and typing the password? – Tom Brossman Nov 24 '13 at 18:37
  • Disable the security measures temporarily and see if it works. Does iwconfig produce anything? – Wilf Nov 24 '13 at 18:51
  • I can't simply scan because I have a hidden SSID. I could try removing the security temporarily but that would be a last resort as I would have to reconfigure a lot of devices on my network. – n0pe Nov 24 '13 at 20:22
1

Try adding the following to your network block in /etc/wpa_supplicant/wpa_supplicant.conf

scan_ssid=1

GUI does not add it for hidden networks. After verifying all my other settings and still not connecting, I added this line, did a sudo ifdown wlan0 then sudo ifup wlan0 and it connected and got an IP.

0

Try ditching the gui and try via command line http://www.howtogeek.com/167425/how-to-setup-wi-fi-on-your-raspberry-pi-via-the-command-line/

  • 2
    You should include the essential parts of the link in this answer to avoid link rot. – syb0rg Dec 4 '13 at 22:54
0

The simpliest way I know is to set up WiFi via command line, in other words not GUI. This is how I have done it and it's working flawlessly:

Make sure /etc/network/interfaces contain the following:

$sudo nano /etc/network/interfaces
auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
auto wlan0
iface wlan0 inet dhcp
pre-up wpa_supplicant -B w -D wext -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf
post-down killall -q wpa_supplicant
iface default inet dhcp


Edit the following file:

$sudo more /etc/wpa_supplicant/wpa_supplicant.conf

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
ssid="YOURSSID"
psk="YOURPASSWORD"

# Protocol type can be: RSN (for WP2) and WPA (for WPA1)
proto=WPA

# Key management type can be: WPA-PSK or WPA-EAP (Pre-Shared or Enterprise)
key_mgmt=WPA-PSK

# Pairwise can be CCMP or TKIP (for WPA2 or WPA1)
pairwise=TKIP

#Authorization option should be OPEN for both WPA1/WPA2 (in less commonly used are SHARED and LEAP)
auth_alg=OPEN
}


I have also found out that some WiFi-dongles go into sleep-mode after about 6 hours. To that I found the following solution:

Edit the file:

$sudo nano /etc/modprobe.d/8192cu.conf

# Disable power saving
options 8192cu rtw_power_mgnt=0 rtw_enusbss=1 rtw_ips_mode=1

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.