1

For my application I have to create a splash screen, So I actually created It but I still get this messages for like 0.1s before my splash screen image shows up. can someone help me to remove them, I am working on a raspberry pi 4 and the os is raspberry pi os lite

my cmdline.txt looks like :

console=serial0,115200 console=tty1 root=PARTUUID=5eef99ab-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait consoleblank=0 loglevel=1 quiet logo.nologo vt.global_cursor_default=0

I tried also with console=tty3 but I had the same result

My config.txt :

disable_splash=1

Can anyone help me please

enter image description here

enter image description here

2
  • Please don't mark the title with [SOLVED]. This is not the way this site works. Everybody can better see and filter that your question has an accepted answer with the green colored Answer Icon in the overview. – Ingo Dec 9 '20 at 19:59
  • I saw that in an other question so I did the same hoping that it could help someone ! but it's okay I noted that thanks ! – mina Dec 10 '20 at 7:22
4

They are the boot diagnostics (specifically known as the HDMI boot screen) and are issued by the built in firmware before Linux actually starts to boot.

Previously, they where controlled by the disable_splash option in config.txt but that function was deprecated Sept 2020.

They are currently controlled by a flag DISABLE_HDM in the boot loader configuration and currently (as at Dec 2020) have two values

  • '0' - this means show the status on boot
  • '1' - this means the status display is disabled

Note: RPT/RPF reserve the right to use other values in the future (play at your own risk).

To update this value:

  1. Update your system to down load the latest eeprom package (sudo apt update && sudo apt -y upgrade && sudo reboot after you have taken a back up.
  2. Start a console session (if you are running the GUI)
  3. Check the current value using the command rpi-eeprom-config (does not need sudo)
  4. Note the value down safely - you may want to return to this value at some point
  5. Use the command sudo -E rpi-eeprom-config --edit to enter the editor (make sure you have the -E after the sudo to maintain the environment.
  6. Make the changes you require
1
  • Thank you so much ! It worked for me ! I just spent a couple of days looking for a solution ! thank you for your help :D , I will edit my question to make it more clear it might help someone – mina Dec 9 '20 at 8:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.