-1

I used to have a Netgear Nighthawk router where my raspberry pi 3 was able to connect to WiFi, ethernet, SSH, everything I needed.

Using the same Pi but now plugged into a TP-Link Archer A9 router, I can not get any connection at all with an ethernet cord. The router interface at (192.168.0.1) does not show a wired connection coming from the Pi either. The router LED glows as if the Pi's ethernet cord is connected. If I connect the Pi to the router through WiFi, I am able to then see the Pi on the TP-Link router's interface (192.168.0.1). If I use the IP address in this interface to SSH, it works! However, it still doesn't have internet access.

For example, when the pi is connected to the router through WiFi, I am able to SSH into the pi and execute the following.

pi@raspberrypi:~ $ sudo ping google.com
PING google.com (172.217.4.78) 56(84) bytes of data.
From 192.168.1.5 (192.168.1.5) icmp_seq=1 Destination Host Unreachable
From 192.168.1.5 (192.168.1.5) icmp_seq=2 Destination Host Unreachable
From 192.168.1.5 (192.168.1.5) icmp_seq=3 Destination Host Unreachable
From 192.168.1.5 (192.168.1.5) icmp_seq=4 Destination Host Unreachable
From 192.168.1.5 (192.168.1.5) icmp_seq=5 Destination Host Unreachable
From 192.168.1.5 (192.168.1.5) icmp_seq=6 Destination Host Unreachable
From 192.168.1.5 (192.168.1.5) icmp_seq=7 Destination Host Unreachable
From 192.168.1.5 (192.168.1.5) icmp_seq=8 Destination Host Unreachable
From 192.168.1.5 (192.168.1.5) icmp_seq=9 Destination Host Unreachable
From 192.168.1.5 (192.168.1.5) icmp_seq=10 Destination Host Unreachable
From 192.168.1.5 (192.168.1.5) icmp_seq=11 Destination Host Unreachable
From 192.168.1.5 (192.168.1.5) icmp_seq=12 Destination Host Unreachable
From 192.168.1.5 (192.168.1.5) icmp_seq=13 Destination Host Unreachable
From 192.168.1.5 (192.168.1.5) icmp_seq=14 Destination Host Unreachable
From 192.168.1.5 (192.168.1.5) icmp_seq=15 Destination Host Unreachable
From 192.168.1.5 (192.168.1.5) icmp_seq=16 Destination Host Unreachable
From 192.168.1.5 (192.168.1.5) icmp_seq=17 Destination Host Unreachable
From 192.168.1.5 (192.168.1.5) icmp_seq=18 Destination Host Unreachable
From 192.168.1.5 (192.168.1.5) icmp_seq=19 Destination Host Unreachable
^C
--- google.com ping statistics ---
21 packets transmitted, 0 received, +19 errors, 100% packet loss, time 928ms
pipe 4
pi@raspberrypi:~ $

Edit: Suggested to run the following commands.

pi@raspberrypi:~ $ ip a && ip r
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether b8:27:eb:c0:4c:d6 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.5/24 brd 192.168.1.255 scope global noprefixroute eth0
       valid_lft forever preferred_lft forever
    inet6 fe80::9caa:4457:4097:e21a/64 scope link
       valid_lft forever preferred_lft forever
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether b8:27:eb:95:19:83 brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.247/24 brd 192.168.0.255 scope global noprefixroute wlan0
       valid_lft forever preferred_lft forever
    inet6 fe80::2305:6f6d:a1c4:9e73/64 scope link
       valid_lft forever preferred_lft forever
default via 192.168.1.1 dev eth0 src 192.168.1.5 metric 202
default via 192.168.0.1 dev wlan0 proto dhcp src 192.168.0.247 metric 303
192.168.0.0/24 dev wlan0 proto dhcp scope link src 192.168.0.247 metric 303
192.168.1.0/24 dev eth0 proto dhcp scope link src 192.168.1.5 metric 202
pi@raspberrypi:~ $ ethtool eth0
Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Advertised FEC modes: Not reported
        Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                             100baseT/Half 100baseT/Full
        Link partner advertised pause frame use: Symmetric Receive-only
        Link partner advertised auto-negotiation: Yes
        Link partner advertised FEC modes: Not reported
        Speed: 100Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 1
        Transceiver: internal
        Auto-negotiation: on
Cannot get wake-on-lan settings: Operation not permitted
        Current message level: 0x00000007 (7)
                               drv probe link
        Link detected: yes
pi@raspberrypi:~ $
6
  • Post the output of ip a && ip r and also ethtool eth0
    – Milliways
    Dec 11, 2020 at 5:17
  • 1
    It was too long to comment, so I edited original post @Milliways
    – Blake
    Dec 11, 2020 at 6:39
  • Do you use static ip addresses?
    – Ingo
    Dec 11, 2020 at 11:22
  • 1
    Reserving an address DOES NOT "register a static IP". You have not specified the contents of configuration files or any other detail, BUT ip a && ip r shows you are connected to 2 different networks. We can only guess why. See How to set up networking/WiFi
    – Milliways
    Dec 13, 2020 at 4:55
  • 1
    Abandoned post by Unregistered user.
    – Milliways
    Dec 27, 2023 at 1:34

1 Answer 1

0

You appear to have a perfectly working network.

Both interfaces are working, although they may not be doing what you expect (we do not know how you managed this or what you expect).

You seem to have 2 different network segments

eth0 is on 192.168.1.x
wlan0 is on 192.168.0.x

Unless you have set static IP Addresses (which is almost always a bad idea) they are connected to different routers.

2
  • So maybe the ethernet connection is remembering the old router for some reason? Thats the same xxx.xxx.1.x gateway
    – Blake
    Dec 13, 2020 at 3:13
  • I didnt change anything in any settings by the way. I simply switched out routers and it is working on every other device.
    – Blake
    Dec 13, 2020 at 3:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.