-2

I recently updated my Raspberry pi3 (non b+) from Raspbian jessie to stretch and then to buster (it's also rocking Retropie 4.7.1 on top of that). And for some reasons the autologin function : raspi-config -> "3 Boot Options" -> "B1 Desktop / CLI" -> "B2 Console Autologin" doesn't work anymore. Whenever I boot the pi it asks me for a login / password.

However the option "B4 Desktop Autologin" works just fine, but that's not what I want...

Any ideas of what could be going on there ? What log to take a look at ?

Thanks for reading

EDIT : additional informations, /etc/systemd/system/getty.target.wants/getty@tty1.service seems to have been edited correcty by raspi-config as I can read read the following line in it : ExecStart=-/sbin/agetty --autologin pi --noclear %I $TERM

  • 1
    If you choose to "upgrade" DESPITE the Foundation warning you are on your own. Skipping a release just makes it worse. It is faster to do a fresh install rather than patch. – Milliways Dec 13 '20 at 22:50
  • I didn't skip a version.... I updated jessie -> buster , buster -> stretch... I have tons of stuff already installed and tweaked it would take me days to reconfigure everything. Also I don't have a direct line with the foundation nor did they sent me a mail warning me about anything. It didn't destroy my debian to upgrade major versions for the past 10 years or so. Thanks for that constructive comment. – aramir Dec 13 '20 at 22:56
  • Did you really end up with Stretch? That's the version before Buster... Agree with the comment above though – Dirk Dec 14 '20 at 0:21
  • good catch I had the order wrong writing this. I did Jessie -> Stretch -> Buster obviously. That would be weird otherwise indeed. – aramir Dec 14 '20 at 0:25
  • Please keep an eye on the Pi blog for upgrade advice - see raspberrypi.org/blog/buster-the-new-version-of-raspbian it states our recommendation is that you download a new clean image and We do not recommend upgrading an existing Stretch (or earlier) system to Buster Too many changes happen that cannot be replicated by others to help. – user115418 Dec 27 '20 at 11:37
0

So I'm still trying to figure it out why the raspi-config edited line doesn't work.

But using : ExecStart=-/sbin/agetty --autologin pi %I in /etc/systemd/system/getty.target.wants/getty@tty1.service seems to be working just fine.

I'll update later if I find any reasons for why the other parameters are not working as I'm running out of time for today.

EDIT : I quickly reintroduced every single parameter given by raspi-config ... and now they all work. I didn't do anything else than remove them, and add them back one by one ... So I don't know.

  • Please mark the answer as the accepted one with a click on the tick on its left side. That prevents your Question from being shown as an unsolved Post to the community and saves them/us a lot of work. – Ingo Dec 20 '20 at 11:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.