4

I got on wednesday my new Raspberry Pi Model B and I tried to install GitLab with the wikis.

The installation went perfectly until I ran:

bundle install --deployment --without development test postgres

After that I waited a long time but nothing happens apart from the output:

# Fetching source index from https://rubygems.org/

During the process "bundle" runs, the CPU has a usage of over 90% and the RES value grows endlessly. I googled much hours and found some topics but nothing worked. (I reinstalled already Raspbian once, because I did not know what to do after ruined everything.)

What should I do now to go on with the installation?

5

Looking at this forum post, here is a modified instruction set from that forum post:

  1. Follow instructions from this installation guide until step 6.

  2. In a separate directory install libv8. Use the newest version, because most issues with libv8 is due to old code not able to be compiled on ARM systems. It isn't possible to install it from Gem.

  3. Continue to follow step 6 till the installation step for Gems.

  4. Add missing config file in /home/git/gitlab. Run:

     $ sudo -u git cp config/puma.rb.example config/puma.rb
    
  5. Edit Gemfile and Gemfile.lock in /home/git/gitlab directory to a clean version of libv8 and therubyracer.

  6. Install node.js:

     $ sudo apt-get install nodejs
    
  7. Continue to install Gems.

It should be ready after that. The first time you access the page it will take a long time to respond (around 15 minutes!). After that the time will be reduced to around 5 seconds for a page.

| improve this answer | |
  • at this step < $ sudo -u git cp config/puma.rb.example config/puma.rb > i've got this error : no such file or directory. Can anyone tell me where's the problem ? thx – user3124252 Feb 11 '14 at 18:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.