0

I'm currently using a Raspberry Pi Zero W running Pi OS Lite. I'm using the following external hats with it:

PiSugar 2 Battery 1000mAh link

Serial PiZero addon link

PiOLED link


Here's my situation: the battery powers the Pi from contact pins the touch the GPIO pins. The pins it uses are 1, 3, 4, 5, 6, and 9. The serial pi (from what I can tell) doesn't overlap these pins with the exception of power and ground. The PiOLED uses power and ground as well as I2C, utilized on pins 3 and 5. The caveat here is that the PiSugar uses those same pins and I2C to transmit battery information. Which is fine, but currently unused.

So the problem, when I boot the Pi completely assembled, GPIO pins 3 and 5 are sometimes at a much lower voltage than expected (~1.4V). When this is the case, the screen will not turn on. The serial connection still works fine as well as all other Pi services. Other times I'll turn the Pi on and those pins will read ~3.1V and the screen turns on. My question is if anyone knows the reason behind this happening. I'm open to any suggestions at this point and am able to run code on it if anyone needs more information.

8
  • Have you tried contacting the supplier? – user115418 Dec 17 '20 at 23:11
  • The supplier of which part? – Justanothermatt Dec 17 '20 at 23:16
  • What have you done to pinpoint the problem? – joan Dec 17 '20 at 23:34
  • I've looked at each piece individually and tried to figure out what causes the voltage drop to no avail. I've tried a new piece of each hat, pi, and SD card. And I've made sure they aren't working on the same I2C address. Basically, everything I could think of or find on Google – Justanothermatt Dec 17 '20 at 23:38
  • Power supply is where I would start – user115418 Dec 17 '20 at 23:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.