4

Sound over HDMI works fine when I login as the default user pi.

I created a new user named for example user1

If I login as this user, no sound plays through hdmi.

I then added this user to most groups the pi user belongs to, such as audio, video, etc except sudo and pi as I do not want this new user to have root access.

Sound over HDMI is still not working (works fine through a usb dongle though, I don't have a 3.5mm jack as this is a pi400)

If I open a terminal, do a su pi and then aplay somesoundorother.wav I get a sound output as expected. However the exact same command as user1 does not output any sound

What is the difference between the defaut pi user and the new user that would cause this behaviour ? Is this a bug ?

Thanks.

Edit: Here is the output of aplay -L

    null
    Discard all samples (playback) or generate zero samples (capture)
jack
    JACK Audio Connection Kit
pulse
    PulseAudio Sound Server
default
    Playback/recording through the PulseAudio sound server
output
input
sysdefault:CARD=b1
    bcm2835 HDMI 1, bcm2835 HDMI 1
    Default Audio Device
dmix:CARD=b1,DEV=0
    bcm2835 HDMI 1, bcm2835 HDMI 1
    Direct sample mixing device
dsnoop:CARD=b1,DEV=0
    bcm2835 HDMI 1, bcm2835 HDMI 1
    Direct sample snooping device
hw:CARD=b1,DEV=0
    bcm2835 HDMI 1, bcm2835 HDMI 1
    Direct hardware device without any conversions
plughw:CARD=b1,DEV=0
    bcm2835 HDMI 1, bcm2835 HDMI 1
    Hardware device with all software conversions
usbstream:CARD=b1
    bcm2835 HDMI 1
    USB Stream Output
sysdefault:CARD=Headphones
    bcm2835 Headphones, bcm2835 Headphones
    Default Audio Device
dmix:CARD=Headphones,DEV=0
    bcm2835 Headphones, bcm2835 Headphones
    Direct sample mixing device
dsnoop:CARD=Headphones,DEV=0
    bcm2835 Headphones, bcm2835 Headphones
    Direct sample snooping device
hw:CARD=Headphones,DEV=0
    bcm2835 Headphones, bcm2835 Headphones
    Direct hardware device without any conversions
plughw:CARD=Headphones,DEV=0
    bcm2835 Headphones, bcm2835 Headphones
    Hardware device with all software conversions
usbstream:CARD=Headphones
    bcm2835 Headphones
    USB Stream Output

also if I use the following command, the sound works : aplay -D sysdefault /usr/share/scratch/Media/Sounds/Instruments/StringAccent.wav

How can I can make this "sysdefault" device the default?

6
  • 1
    "I then added this user to most groups the pi user belongs to" -> Just in case: Those changes won't be in effect for existing logins by that user, only future ones.
    – goldilocks
    Dec 19 '20 at 17:07
  • Yes, I rebooted multiple times while doing all of this so I don’t think that’s the issue
    – jfoucher
    Dec 19 '20 at 17:19
  • Check the output options in the GUI - Pi seems to mess around with these that other users do not...
    – user115418
    Dec 19 '20 at 20:40
  • Where exactly in the gui ? if I right click on the loudspeaker icon in the top bar it shows HDMI wiith a green check mark next to it.
    – jfoucher
    Dec 20 '20 at 12:27
  • Have you tried editing the ~/.asoundrc file? Dec 23 '20 at 15:59
1

If you're using raspbian you could try this:

In the top right, there is a volume icon, if you right click that you should probably see the HDMI option, make sure there's a green check mark next to it.

HDMI Option

1
  • Yes there is a green check mark next to the hdmi entry.
    – jfoucher
    Dec 29 '20 at 18:10
1

See if you can set the default audio sink device in Pulse Audio Volume Control settings, as described in this answer. Pulse settings are user-specific, so this has to be done for every user you create.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.