I am trying to connect to a raspberry pi zero (and a pi3) via uart and USB (USB to TTL YP-01)

I am connected to pin 8, pin 10 and a ground. tx -> rx, rx -> tx

I have tried everything on this url

How do I make serial work on the Raspberry Pi3 (or later model)

and I still get nothing in minicom


dwc_otg.lpm_enable=0 console=tty1 console=ttyUSB1,9600 root=PARTUUID=aae5ae38-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait



ls /dev:

localhost: # ls /dev/
acpi_thermal_rel  fuse                      log     loop26  loop44  loop62              null      snd     tty2   tty38  tty56   ttyS16  ttyS6    vcs6    vfio
autofs            gpiochip0                 loop0   loop27  loop45  loop63              nvram     stderr  tty20  tty39  tty57   ttyS17  ttyS7    vcs7    vga_arbiter
block             hidraw0                   loop1   loop28  loop46  loop7               port      stdin   tty21  tty4   tty58   ttyS18  ttyS8    vcsa    vhci
bsg               hidraw1                   loop10  loop29  loop47  loop8               ppp       stdout  tty22  tty40  tty59   ttyS19  ttyS9    vcsa1   vhost-net
btrfs-control     hidraw2                   loop11  loop3   loop48  loop9               psaux     system  tty23  tty41  tty6    ttyS2   ttyUSB0  vcsa10  vhost-vsock
bus               HID-SENSOR-2000e1.2.auto  loop12  loop30  loop49  loop-control        ptmx      tpm0    tty24  tty42  tty60   ttyS20  ttyUSB1  vcsa2   video0
char              hpet                      loop13  loop31  loop5   lp0                 pts       tpmrm0  tty25  tty43  tty61   ttyS21  udmabuf  vcsa3   video1
console           hugepages                 loop14  loop32  loop50  lp1                 random    tty     tty26  tty44  tty62   ttyS22  uhid     vcsa4   watchdog
core              hwrng                     loop15  loop33  loop51  lp2                 rfkill    tty0    tty27  tty45  tty63   ttyS23  uinput   vcsa5   watchdog0
cpu               iio:device0               loop16  loop34  loop52  lp3                 rtc       tty1    tty28  tty46  tty7    ttyS24  urandom  vcsa6   wmi
cpu_dma_latency   iio:device1               loop17  loop35  loop53  mapper              rtc0      tty10   tty29  tty47  tty8    ttyS25  usb      vcsa7   xconsole
cuse              iio:device2               loop18  loop36  loop54  mcelog              sda       tty11   tty3   tty48  tty9    ttyS26  userio   vcsu    zero
disk              iio:device3               loop19  loop37  loop55  media0              sda1      tty12   tty30  tty49  ttyS0   ttyS27  v4l      vcsu1
dm-0              iio:device4               loop2   loop38  loop56  mei0                sda2      tty13   tty31  tty5   ttyS1   ttyS28  vcs      vcsu10
dm-1              iio:device5               loop20  loop39  loop57  mem                 sda3      tty14   tty32  tty50  ttyS10  ttyS29  vcs1     vcsu2
dri               initctl                   loop21  loop4   loop58  memory_bandwidth    sda4      tty15   tty33  tty51  ttyS11  ttyS3   vcs10    vcsu3
drm_dp_aux0       input                     loop22  loop40  loop59  mqueue              serial    tty16   tty34  tty52  ttyS12  ttyS30  vcs2     vcsu4
fb0               kmsg                      loop23  loop41  loop6   net                 sg0       tty17   tty35  tty53  ttyS13  ttyS31  vcs3     vcsu5
fd                kvm                       loop24  loop42  loop60  network_latency     shm       tty18   tty36  tty54  ttyS14  ttyS4   vcs4     vcsu6
full              lightnvm                  loop25  loop43  loop61  network_throughput  snapshot  tty19   tty37  tty55  ttyS15  ttyS5   vcs5     vcsu7

connection string:

minicom -c on -D /dev/ttyUSB1

stty -F /dev/ttyUSB1:

speed 9600 baud; line = 0;
-brkint -imaxbel

What is the trick to bring up uart on a USB ttl?

UPDATE with info from a comment:
How can I run raspi-config if I cannot even get to the command line? I am trying to connect to the serial console.

  • 2
    The linked Answer has NOTHING to do with USB.
    – Milliways
    Dec 21, 2020 at 3:28
  • I can find a serial port.
    – brad
    Dec 21, 2020 at 3:47
  • 2
    It is unclear what you are asking or what you have tried - or even what you are trying to do.
    – Milliways
    Dec 21, 2020 at 3:54
  • @Milliways Does this help? bpa.st/HK5Q I am trying to connect USB (rs323) to serial (GPIO pin 8 and 10)
    – brad
    Dec 21, 2020 at 4:39
  • 1
    What is at the other end - a connection has 2 ends! How are you testing it?
    – Milliways
    Dec 21, 2020 at 5:12

2 Answers 2


First restore your cmdline.txt to the original.

Run sudo raspi-config and configure serial (and disable serial console).

You then communicate to dev/serial0 NOT /dev/ttyUSB1.

I assume the device (whatever it is) supports 3.3V logic levels (and has nothing to do with RS232) and is connected to some other computer (which needs to be appropriately configured).

  • How can I run raspi-config if I cannot even get to the command line? I am trying to connect to the serial console. I have no /dev/serial0 which is which I posted my entire /dev directory.
    – brad
    Dec 21, 2020 at 6:13
  • @brad: Do you have another computer - beside the RPi? If so, is that the device you want to use to communicate with the RPi?
    – Seamus
    Dec 21, 2020 at 6:26
  • @brad You are totally redefining the Question - there was no mention of this in your Question (which is where ALL detail belongs)
    – Milliways
    Dec 21, 2020 at 6:53
  • When did I eve say I had a computer monitor? You guessed
    – brad
    Dec 21, 2020 at 14:54
  • @Seamus I would like any communication with this device at all. Anything. Smoke signals would work. A serial connection will be ok.
    – brad
    Dec 21, 2020 at 14:56

As far as I understand you want to connect to the serial debug console with using a USB to TTL (RS232) serial cable. This usually works without any problems if using the right terminal software. I haven't tried minicom for this. I know that screen and tio works, where I prefer tio. It is a nice tiny program just made for a serial console without any overhead. You also should check your connections. Have a look at What is the correct way to connect serial console on RPi4 Model B?.

  • If that worked, iw wouldn't be posting my friend. That is what is failing.
    – brad
    Dec 21, 2020 at 14:57
  • @brad If you want to get better answers you should better explain your problem. I'm not the only one you confused. Did you try tio or screen? What error messages they give? Maybe your USB to TTL serial cable is broken or wrong? Have you tried with a fresh flashed Raspberry Pi OS Lite?
    – Ingo
    Dec 21, 2020 at 15:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.