4

I have a Raspberry Pi Model B running Raspbian NOOBS, which I'm preparing to use as a media centre / Node.JS server.

I have followed various tutorials and managed to get a premade Raspbian image up and running with Qemu on my Windows 8 laptop. I am, however, unable to get a .img file which I made using Win32DiskImager (a clone of the SD card which contains my functioning Raspbian install) to boot in Qemu.

The image and Qemu installation provided at http://sourceforge.net/projects/rpiqemuwindows/ is nice and clean and quick and it functions, but swapping the .img for my own, I receive the following messages in the Qemu window:

No filesystem could mount root, tried: reiserfs ext3 ext2 ext4 cramfs minix vfat ntfs romfs fuseblock Kernel panic - not syncing: VFS: unable to mount root fs on unknown-block(8,2)

I'm using the following command sequence to run Qemu:

$ qemu-system-arm.exe -M versatilepb -cpu arm1176 -hda raspbian.img -kernel kernel-qemu -m 192 -append "root=/dev/sda2"

I tried different sda values, and I tried using rootfstype=msdos and rootfstype=fat32 since the SD is FAT32 formatted. I've tried using qemu-system-armw.exe instead of qemu-system-arm.exe. I've tried different versions of Qemu while following different tutorials, all with similar results -- an unmountable filesystem. Yet Qemu shows 5 partitions before it errors out. I tried reimaging the SD card -- and ended up with an identical image (same MD5, same total filesize).

So far every tutorial or forum thread I've found discusses creating a new installation for emulation, whereas what I need is to have a clone of my existing, configured system available to me while I'm away from home. Is there a method to achieve this using tools available for Windows 8?

I have read through the following tutorials:

2

I know this is an old question but since it comes up in Google searches and I was looking for the same information, I'll post what I've found.

There's a solution for Linux based qemu here and there's Windows based information here.

  • This looks promising. I will give it a try this week. If it works, you've got yourself a green checkmark. If it doesn't, it's still the most promising lead I've seen since I posted this question a year and a half ago. :) – Adrian Jul 14 '15 at 16:31
  • I didn't quite get my image up and running in Qemu. There are a lot of imitations with Qemu and I've reverted to using a real RPi again. – BartmanEH Jul 24 '15 at 14:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.