1

I just bought a Raspberry Pi on Adafruit website with this HDMI<->VGA cable to plug it on my second monitor. The problem is it doesn't show anything on the screen, it's totally black. So I tried on my TV with HDMI and it worked perfectly. I read I had to modify the /boot/config.txt file, so I did it with vi and changed disable_overscan to 1 hdmi_force_hotplug to 1 hdmi_group to 2 hdmi_mode to 58 (because my screen is 1680*1050) config_hdmi_boost to 4 I saved the file and bring it to my desk, plugged into the screen and the screen LED is blue (so it receives a signal, otherwise it's orange) but it stays all black (but on) Have you got an idea ? The screen is a Hyundai one, I think it's five years. Thank you

  • I just forgot to precise : I installed Raspbian using NOOBS and NOOBS was working on my desk screen. – Thomas Kowalski Nov 27 '13 at 11:15
  • I just had the idea to connect the adapter to my PC, and then to plug the adapter into my VGA cable, and it actually worked (i'm typing this looking at my second monitor ^^) so have you got any other idea ? – Thomas Kowalski Nov 27 '13 at 11:54
  • THe screen has to be widescreen? – Piotr Kula Nov 27 '13 at 12:50
  • 1
    My screen is 1680x1050 so 16:10... – Thomas Kowalski Nov 27 '13 at 13:37
  • 1
    And I don't think it's this, I installed Pidora from NOOBS and then it worked. – Thomas Kowalski Nov 27 '13 at 13:37
2

I tried your answer but did not work. So I post the one which finally worked for me :

disable_overscan=0
hdmi_force_hotplug=1
hdmi_group=2
hdmi_drive=2
overscan_left=20
overscan_right=20
overscan_top=20
overscan_bottom=20

The complete one can be found at pastebin.com/kkEG8w7M

0

i have the same adapter, here is what worked for me and my VGA monitor.(make sure the drive, group, and mode is supported by your monitor) below sets to 1280x1024. SSH into you Pi and "sudo nano /boot/config.txt" or pop the card into your reader and mod the config.txt from there.

arm_freq=860
core_freq=380
gpu_freq=350
force_turbo=1
disable_overscan=1
hdmi_force_hotplug=1
hdmi_drive=2
hdmi_group=2
hdmi_mode=35
hdmi_edid_file=1
hdmi_ignore_edid=0xa5000080
decode_MPG2=
decode_WVC1=
gpu_mem=128
start_file=start_x.elf
fixup_file=fixup_x.dat

the settings have to be in the order as above if any of the hdmi are out of order it will fail, Raspbmc messes the config.txt file up if you use it.

0
disable_overscan=0
hdmi_force_hotplug=1
hdmi_group=2
hdmi_drive=2
overscan_left=-48
overscan_right=-48
overscan_top=-48
overscan_bottom=-48

We found that if you apply a negative overscan as above to certain monitors this will solve the issue. It shouldn't but......=o It do! We run these monitors and pi's 24.7 without issue

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.