0

I gave two raspberry pi 4s (8 GB RAM) as a gift (I generally use Linux but am fairly new to these :) ), and wanted to watch Netflix and Youtube on them (for example). Yet Youtube has a lot of screen tearing (I think that's the word). I've tried both of the answer's from here on Raspberry Pi #1, but neither fixed the issue.

Next, I found Netflix straight doesn't work. I looked up the Netflix issue and found this Tom's Hardware page (and many of the same exact solution) - this installs an alternative Chromium supposedly more apt for media. But trying it on Raspberry Pi #1 (which I've modified according to the first link) yielded this message:

"Error: Invalid desktop entry file: '/usr/share/applications/chromium-media-browser.desktop'"

(If I go to that file, there doesn't appear to be anything too strange, of course I can share its contents if needed)

(and no fixes to the original Chromium)

On Raspberry Pi #2, which is pretty much vanilla Raspbian, I ran the Media Edition installer, and it's there and I can run it... except still Netflix doesn't work, and neither does Youtube.

Not only that, but if I try to go to chrome://settings or chrome://plugins, for example, it brings me to the "Aw, Snap!" mage for the former, and "This site can't be reached" for the latter; I'm not sure if it did that before, but it seems very odd. I can't even access the settings (the same I guess as chrome://settings).

I'm wondering what is going on here, and how to get these to work.

0

From what I have found 32bit Raspberry Pi os uses chromium-browser but 64 bit uses chromium as the executable. I edited the .desktop file to call chromium instead of chromium-browser and the browser kicked in. I have not had time to fully test but it is possible the changes are for 32 bit only. At this stage I am not seeing an improvement in Youtube, tearing exists.

1
  • check out my answer below! I think it will help you; thank you for your answer, it helped prod me along where to look for help – Chris Dec 29 '20 at 7:51
0

I found a half-solution. I'm not sure what I was running before (I'll investigate further in a bit), but at least this worked. From raspberrypi site, I got the 32-bit OS version. I'm not sure if even before I didn't have this, but either way, this one works ("Raspberry Pi OS with desktop"). If I do the solution from Tom's Hardware from my question above, then it all works!

I figured this out in a sort of indirect way (I still don't really know what's going on). The Tom's Hardware method is really the vpetkov method, and I was looking at the most up-to-date blog post of his on this matter. In particular, I found a comment from a "John_NS" stating (basically what boxhead72 says):

Looks like this might be raspberry pi 64 bit thing. From what I can see/figure out the 32bit Raspberry OS uses chromium-browser for a directory while 64bit uses chromium.

You can change that to chromium but it doesn’t install the wildvine files properly, so nothing works – it just creates a file called “chromium-browser”.

Above my skills to figure out how to fix it.

And to this, vpetkov (the caretaker) replies

LibWideVine is not supported on 64 bit ARM systems currently to my knowledge.

If that changes, applying this to the Pi should be relatively easy. Google is really driving this effort unfortunately, and it seems they (again, currently) have no interest in changing it.

So I decided to go for an explicitly 32 bit OS, unsure if before I had 64 bit... and the one at that end of the link worked! I tried Netflix and it seems to function, and youtube is looking good so far (I test with this video because knife sharpening really strained the system, whatever it was that was being strained).

So it's somewhat an unsatisfactory, but serviceable, workaround. It seems 64 bit still needs to be properly hacked to function, and perhaps we are at the mercy of Google (?) according to vpetkov.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.