1

Following these directions to install nodes on a Raspberry Pi

Using the following to install chrome browser

sudo apt-get install chromium-browser However, after installing, when I try launching(via terminal) get the following error

error [1:1:1827694911:ERROR:nss_util.cc(692)] Failed to load NSS libraries.

Anyone know how to resolve this?

3
  • Did you test is using chromium --kiosk http://www.google.com/ like it tells you in the tutorial?
    – Dom
    Nov 27, 2013 at 16:58
  • according to this site github.com/SamyPesse/tv.js/issues/19 you can Fix the NSS Libraries issue by symlinking /usr/lib/arm-linux-gnueabihf/nss/ too /usr/lib/nss Nov 27, 2013 at 17:43
  • @user2005121 Have you got anywhere with this? If so, please either mark the answer that helped you, or create a self-answer with the steps you took to solve it. Jan 27, 2014 at 15:38

2 Answers 2

3

The symlinking worked for me and for my RPi, as in this worked:

sudo ln -s /usr/lib/arm-linux-gnueabihf/nss/ /usr/lib/nss

1
  • You do know that you can mark a self-answer as the answer to the problem? Please mark this as such, we are trying to get the site Q:A ratio up and that would help us a lot! Thanks! Mar 23, 2014 at 17:07
1

try:

sudo apt-get purge chromium-browser
sudo apt-add-repository ppa:chromium-daily/stable
sudo apt-get update
sudo apt-get install chromium-browser

if that doesn’t work, try Steve's solution by symlinking /usr/lib/arm-linux-gnueabihf/nss/ to /usr/lib/nss:

sudo ln -s /usr/lib/arm-linux-gnueabihf/nss/ /usr/lib/nss
2
  • tried the latter now get 2 warnings (process:2479): Gtk-WARNING **: Locale not supported by C library. Using the fallback 'C' locale. (chromium:2479): Gtk-WARNING **: cannot open display: Nov 28, 2013 at 19:07
  • 1
    @user2005121 try this command dpkg-reconfigure locales Nov 28, 2013 at 22:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.