4

enter image description hereI am using raspberry pi 4b after successfully installation of raspbian os i connected the pi with raspberry display (official raspberry pi 7 inch display) then error msg appears as kernel panic cant allocate swiotlb buffer before and cant allocate dmabouncer buffer now Please help

6
  • successfully installation of os which OS? where did you get it from? I wonder if you can take a picture of the whole screen rather than part of it - also what is this raspberry display you've connected to? – Jaromanda X Dec 29 '20 at 9:52
  • I have installed raspbian os and display is official raspberry pi 7 inch display. Photo is of whole screen only one line is not visible. – vaibhav kadam Dec 29 '20 at 11:27
  • Raspbian is outdated. You should use the up to date Raspberry Pi OS. – Ingo Dec 29 '20 at 18:29
  • was hoping to see the last SUCCESSFUL boot operation just above what you've taken a picture of - maybe connect to a TV/Monitor - you may see more above the error to be able to pinpoint where in the boot process it has failed – Jaromanda X Dec 29 '20 at 22:59
  • confirming one more thing - other than the 7 inch raspberry pi display, you have nothing else connected to the pi and have made absolutely no changes to the boot partition? – Jaromanda X Dec 29 '20 at 23:01
4

I ran into this same issue with a new install of Pi OS after setting the GPU memory to 896 MB in raspi-config.

To fix it without reinstalling:

  1. Put the SD card in another computer that can read the "boot" filesystem. I believe it is a FAT32 filesystem.

  2. Open "config.txt" and alter the "gpu_mem" setting. Set it to something like 512 or lower.

I don't know what the upper limit is, but 512 worked for me and is recommended as the maximum value for a Pi with 1GB memory or greater.

https://www.raspberrypi.org/documentation/configuration/config-txt/memory.md

3
  • The upper limit is 512. Nobody should need that amount of GPU RAM, Start with 192 and work from there. – Dougie Jan 7 at 16:46
  • Just hit this... why is the upper limit in the UI widget 896? – Gabe Jan 10 at 21:17
  • Had the same issues. After reading a bit, this setting is really just for video decoding and the desktop -- 3d applications override this anyway, so no need to set it so high. – Felix Dombek Jan 11 at 23:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.