1

I have bought an "Official Raspberry Pi 7" Touchscreen Display" and a raspberry pi, i have flashed the sd card with Kali Linux, but when i turn the pi on, there is nothing, but a white screen. I have configured it, and it gets detected.


I have now switched to Raspberry Pi O/S, and its the same


Pictures: https://imgur.com/a/kfNFVbw

The red is at pin 6 now.

5
  • 1
    Try Raspberry Pi OS. – CoderMike Dec 29 '20 at 17:49
  • Any reason to expect it to work? I believe it's a kernel patch on Raspberry Pi O/S. As Kali is really not an O/S for end users (it's more a toolkit) support is better on the Kali forums - for example forums.kali.org/… - close vote from me. – user115418 Dec 29 '20 at 19:33
  • 2
    I’m voting to close this question because Kali is not an end user O/S. – user115418 Dec 29 '20 at 19:33
  • Post a photo showing both ends of the ribbon cable inserted in the Pi and screen circuit board connectors. What power supply are you using? – CoderMike Dec 29 '20 at 21:18
  • 'The red is at pin 6 now.' this is wrong, pin 6 is ground. – CoderMike Dec 30 '20 at 15:26
1

Are you sure your Pi end of the cable is inserted fully?

I've used red cable pin2 5V, black cable pin6 Ground.

https://pinout.xyz

enter image description here

4
  • 1
    The Pi end of the cable is inserted fully, i have changed the cables to what you said, but it's the same. – Alexandermss Dec 30 '20 at 15:32
  • 1
    Maybe you've damaged the screen/board by having the 5V and Gnd the wrong way round. Has this screen ever worked? – CoderMike Dec 30 '20 at 15:51
  • 1
    It haven't ever worked, the first time i tried it, it the cables was correct in it, i have just tried different things after that. – Alexandermss Dec 30 '20 at 15:56
  • 1
    Sounds like you need to return it. – CoderMike Dec 30 '20 at 16:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.