0

enter image description hereenter image description hereKeyboard modelmodel A1314 Works fine except that I cannot generate a tilde. The ~ key gives me a >

2
  • Try pressing "Option + N " Or this link. superuser.com/questions/64072/…. – Toly Antonov Dec 29 '20 at 23:17
  • Try configuring your system for a US keyboard rather than UK (default) with sudo dpkg-reconfigure keyboard-configuration. – Dougie Dec 30 '20 at 14:03
2

You need to set the keyboard type to be 'Macintosh' and not GB.

This can be done from the GUI menu or from the raspi-config program (sorry no Pi handy today).

Leave your location and language as GB / English.

5
  • I have the keyboard as Macintosh: 0XKBMODEL=Macintosh and XKBLAYOUT' ="us" sudo dpkg-reconfigure keyboard-configuration come back with: /var/lib/dpkg/info/keyboard-configuration.config: 1: /etc/default/keyboard: 0XKBMODEL=Macintosh: not found. (I have some screenshots but being a bit new round here I dont know if I can add them – forestDM Dec 30 '20 at 23:06
  • Can possibly get a Pi up in the morning - the picture is of a U.K. keyboard (pound on the 3 dollar on the 4). Check via raspi-config. Is your keyboard Bluetooth or usb? You can add pic via editing the question not in comments. – user115418 Dec 30 '20 at 23:36
  • No big rush on this. It's a problem I also have with a Mac Aluminium KB on a Pi4 (RaspiOS) I have added a couple of pics although these tell the same story as my earlier comment. – forestDM Dec 31 '20 at 21:41
  • Is the keyboard option English (UK, Macintosh) on the Pi? I know I set that on a Debian 10 VM. (No where yet with Pi - mind not good this weekend hence surfing at 4AM). – user115418 Jan 3 at 3:56
  • I presume by "keyboard option" you mean - /etc/default/keyboard. Where OXKBMODEL=Macintosh See top pic – forestDM Jan 3 at 21:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.