1

After attempting to add Raspberry Pi OS to my SD card using Raspberry Pi Imager v1.5 on Windows 10, the install abruptly threw an error about a third of the way through writing. Now the SD card cannot be found on either Windows 10 or OSX disk utilities. Has anyone come across this error before and found a remedy?

I purchased this kit and am using the 32 GB SD card provided with the USB adapter.

(Note: I'm not asking how to remedy a 'lost' SD card -- I know that's outside of this forum. That said, off-hand suggestions on the subject are welcome :-) )

1
  • 1
    If the disk is no longer recognized at all (and does not even show up in the device manager), then it's likely it's just broken. Try another one. – PMF Jan 2 at 7:12
2

I'm not quite sure I understand all of your question - e.g. when you say "attempting to add RPi OS to [your] SD card". I think you should have only one image installed on an SD card.

Next - SD cards are not the sturdiest things, so it's always a possibility that it has simply failed. If it were me, I would try again:

  1. You might try rufus instead of RPi Imager. I've not tried RPi Imager, but rufus has been around a while longer & has a good reputation.

  2. Download a fresh image from the RPi download page

  3. Use rufus to write the image file you've downloaded to your SD card.

After you've successfully written the image to your SD card, the only thing you will "see" in Windows or macOS will be the boot partition (boot is formatted w/ FAT32, whereas / is ext4). Follow the steps you took before (creating a blank file named ssh in boot, etc.). Plug it in, and try to boot again.

2
  • Add = transfer? Yes, I just mean the one image -- it was a blank SD card before, and now I want the OS on there. Anyway, I tried everything again on an old 8 GB SD card and everything is peachy, so it was probably a bad SD card. – calcium3000 Jan 3 at 20:12
  • @calcium3000: There's no need to assume your SD card is bad. The fsck command and its underlings will give you the facts. If you're interested, here's how to verify your assumption – Seamus Jan 3 at 22:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.