I bought an RPi 4 recently for my son to play GCompris and other educational games. My daughter has an exactly similar setup since before, which works well. When I install RPi OS and then GCompris I can start the game, but as soon as I click on a button anywhere in the game it hangs and won't proceed.

I am unsure on how to proceed to debug this issue. Does anyone recognize the issue I am having, or have an idea of what might be wrong?


3 Answers 3


apparently it has a bug.(likely to be a firmware issue with sound driver)

start it with the -m option to turn off sound

either from a command shell or click the menu option with right mouse button to go into edit mode for the entry and adjust properties, desktop entry and put a -m option at the end of the command (ensure you have a space before that -m !!)

  • Yep, that works! A shame it doesn't work with sound though, any idea of when that might be fixed? Also odd that it works on the other RPi4 I have it installed on without the '-m' flag (still no sound though). Luckily I found it on Android, so they can play it with sound there until it gets fixed for the Pi. Thanks again! Commented Jan 14, 2021 at 18:19

Check if you have installed gstreamer1.0-pulseaudio package --- this other solved cases (https://github.com/raspberrypi/firmware/issues/1516) and should allow you to play with the sounds.


To successfully run ./gcrompris-qt.sh on my Raspberry Pi 400, I needed to do these commands first:

sudo apt install gstreamer1.0-pulseaudio
sudo apt install libpulse-mainloop-glib0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.