0

So i have installed Arch on my raspberry pi but the ssh isn't enabled because port 22 seems to be closed. Is there anyway I can enable it without access to the console?

5
  • 2
    You expect that you can enable SSH without having access to the system? That obviously won't work. I recommend connecting a screen to it. – PMF Jan 6 at 19:36
  • 1
    This sounds like an arch question... have you tried there? – Seamus Jan 7 at 0:19
  • raspberrypi.org/documentation/remote-access/ssh Point 3 may helpful for you. After enabling SSH, you require static IP address for Ethernet interface or WiFi configuration for auto connect WiFi at startup for connecting to RPi with your machine/network. – secure Jan 7 at 6:46
  • So this is a headless system? Is ssh already installed? Then you may just set the symbolic links for systemd manually while having the SD connected to a PC. So after reboot ssh will be available. – FelixJN Jan 7 at 11:50
  • I installed rasbian and there you have to drop a 0 byte file called "ssh" on a certain place, see here: raspberrypi.org/documentation/remote-access/ssh . But you certainly have to look into the documentation of arch linux for something similar. – Keks Dose Jan 7 at 13:57
1

When you follow the instruction from https://archlinuxarm.org/platforms/armv8/broadcom/raspberry-pi-4 ssh is already enabled. You can connect to your raspberry pi with the IP address given by your router.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.