0

It worked great until something happened during an update (not sure what). Pi had been set to boot from USB and worked fine. It now hangs during startup and, depending which USB drive unit (SanDisk 32/64/128) I use, it shows the skeleton screen or a blank screen or a flashing combination of both ultimately resulting in the "NO SIGNAL" on the HDMI screen. This happens also while trying the SD card slot as well. I have re-imaged the EEPROM (it shows a green screen), re-imaged several iterations of the OS and tried booting from the SD card slot as well as USB - no luck. All my other PIs work great - using the same HDMI screen, all using CanaKit power supplies and cables.

What I want to do is to apply a full factory reset to clear whatever BBs (BadBits) are rolling around inside and start over with it again.

Is there a way to do a total reset back to factory, Out-Of-The-Box condition?

2
  • 1
    since you've "recovered" the EEPROM ... a fresh image of raspberry pi OS should be "out of the box" condition Jan 6 at 23:59
  • Thank you for your reply - That's what I thought would happen, but it doesn't seem to have had the desired effect. I'm wondering whether having initially set it up for USB boot (which worked perfectly for some time) is now permanent.
    – valex777
    Jan 7 at 8:03
2

With a modified EEPROM you have to recover it to factory settings before you can use a fresh flashed Raspberry Pi OS that will give you the default setup. At Raspberry Pi 4 boot EEPROM you will find:

recovery.bin

At power on, the BCM2711 ROM looks for a file called recovery.bin in the root directory of the boot partition on the sd-card. If a valid recovery.bin is found then the ROM executes this instead of the SPI EEPROM image. This mechanism ensures that the bootloader SPI EEPROM can always be reset to a valid image with factory default settings.

With a search for recovery.bin on my RasPi I found:

rpi ~$ sudo find / -xdev -iname recovery.bin
/usr/lib/firmware/raspberrypi/bootloader/stable/recovery.bin
/usr/lib/firmware/raspberrypi/bootloader/beta/recovery.bin
/usr/lib/firmware/raspberrypi/bootloader/critical/recovery.bin

I would say, the stable version is the one you should try first.

2
  • Will copying that file from a working Pi to the boot partition of an SD card for the (as of now) non-booting Pi be the procedure?
    – valex777
    Jan 9 at 2:28
  • BTW - I have already downloaded and run the EEPROM bootloader rescue image more than once and got the rapid green led as well as the green HDMI screen which, they say, should restore the bootloader to factory default - this also has not helped.
    – valex777
    Jan 9 at 2:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.