0

It seems like the Ethernet card on my new pi is dead. I just started playing with my new pi but i cant get the network to work. I run Latest recommended raspbian downloaded from raspberrypi.org i have a 8gb sandsik SDHD 4 micro sd card in the sd adapter it was delivered with.

I have tried to power my pi both from a 2a powered usb hub (can power my MK 802 without issues with a HDD attached) and i have also used a 1a phone charger with the keyboard and mouse connected to the powered hub

I have tried 2 ethernet cables that works with other computers and connected to 4 different ports on 2 routers (Apple airport extreme)

I have not seen the connection led on the routers blink once

When i start my Pi the LNK blinks two times for a fraction of a second with a few seconds apart FDX and 100 leds i have not seen blink once

i have started with nothing but power and network cable no difference

ifconfig says no packages are sent or recieved on eth0 ifup get no DHCPOFFERS ping anything but localhost gets unknown host

looking at the boot log i find nothing i can link to a etehernet card

any sugestions on what can be wrong

  • Connection it to a display should give you some more info. Do any of the other leds light up or blink. Most likely you written the sd card incorrectly. – Gerben Nov 30 '13 at 15:02
  • 2
    The network unit in the Pi is most likely dead i went and bought a new Pi today and it worked like a charm with all the same gear connected to it. So tomorrow my first pi is going back to where i bought it from – siven Dec 1 '13 at 21:22
  • 1
    @syb0rg I humbly disagree. A defective unit is always a possibility (though not very likely), so someone else could have the same problem. @siven good luck with your new Pi. – Gerben Dec 2 '13 at 14:06
  • @Gerben Good point, I retract my comment. While it is a possiblilty, it should be the last consideration of the cause of the problem. – syb0rg Dec 2 '13 at 19:14
  • possible duplicate of Why Isn't My Ethernet Working? – RPiAwesomeness Feb 21 '14 at 15:09
2

connecting all gear to another Pi worked like a charm so the unit i have is defective and will be returned tomorrow

  • 1
    If you have not overclocked or done any hardware hacking, you should be able to take it back - Pi Warranty . the odd thing is, if the USB ports work, the Ethernet should work as they are controlled by the same chip... Probably the connector on the board itself. – Wilf Dec 1 '13 at 21:27
0

Have you tried going to /etc/networking/ and tried changing the config file called interfaces Try setting it up with a static IP see if that works. I don't use the wifi. Also if you use a wireless keyboard with a USB receiver and the USB wifi adapter just remember they are both 2.4GHz. I've heard people having issues with this because their operating off the same frequency. I haven't had an issue but I've heard people have.

If you want to try using a ethernet cable and set up the interfaces file for static IP you will need to find two things.

1.) The routers IP address also know as the gateway IP address. 2.) A IP address that is not being used by another device in your network. So get on another computer and do a ifconfig (using mac) or ipconfig(using windows command prompt). This should tell you what address your computer is using. Go a few above it. So if your computer is using lets say 10.0.0.2 then chose 10.0.0.20 for your pi and you should be fine.

Here is what your interfaces.config file probably will look like:

auto lo

iface to inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicat.conf
iface default inet dhcp 

If your going to hardline the pi to your router do the following:

auto lo

iface to inet loopback
iface eth0 inet static //This needs to be changed from dhcp to static

              address ##.##.##.## //This is the IP address of your pi.
              netmask 255.255.255.0 //This should work for you as a netmask IP
              gateway ##.##.##.## //This is the IP address of your router

iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicat.conf
iface default inet dhcp
  • I don't know what operating system you are referenced but with Raspbian Stretch (what the OP used) there is an entry in /etc/network/interfaces: # Please note that this file is written to be used with dhcpcd # For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'. You completely ignore dhcpcd in your answer. You cannot simply modify /etc/network/interfaces without respect to dhcpcd. – Ingo Jan 4 at 20:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.