I am trying to boot my Raspberry pi 4b from an SSD. After following the most recent instructions I could find for allowing booting via USB (updating bootloader, setting boot order), I installed Raspberry Pi OS on the ssd with Etcher. Then I ejected the SSD and plugged it back in so that I could add the ssh file, but I got "The disk you inserted was not readable by this computer."

Tried booting the pi from it anyway but it failed (never showed up on the network).

Additional info: The SSD is branded 'Vansuny' and identifies as 'JMicron Tech Media' in disk utility. Etcher is running on a Mac. Also tried Raspberry Pi imager.

Appreciate any thoughts.

  • 1
    JMicron Tech - some jmicron USB to SSD devices simply will not boot on a pi anyway - personally, I've never had an issue with ASMedia Technology USB to SSD devices - cheapest ones are ugreen brand - just go the USB 3.0, no need for USB 3.1 as the pi won't achieve 10Gbit Jan 14, 2021 at 1:31

2 Answers 2


I have an RPi4 running from an SSD for almost a year now. At that time it wasn't possible to boot directly from an SSD, but it is possible to change the boot option so that the SSD will be used for /root. Perhaps that's an option for you.

If I remember correctly, I used this page as a guide, but since then the information seem to have changed. It looks like it's now possible to boot directly from an SSD, but according to the comments it's not full proof yet.

I did the following to run my RPi4 from an SSD. It still boots from the SD card but after that only uses the SSD.

Basic setup

  • Write an official Raspbian image to a fresh SD card.
  • Copy an empty file ssh and (for wireless access) your wpa_supplicant.conf to the card.
  • Boot the RPi from the SD card. It should now have an IP in your network (I use Slitheris to quickly identify IP's on my network) and you should be able to SSH into it with PuTTY or so.

Prepare the SSD

  • Plug the SSD into a USB3 port of the RPi. The drive will probably be mounted as /dev/sda1. I'm no Linux expert at all, so not sure of that. Check with sudo fdisk -l and change below if necessary!

  • Unmount, format and re-mount the SSD:

    sudo umount /dev/sda1

    sudo mkfs.ext4 /dev/sda1

    sudo mkdir /media/rootdrive

    sudo mount /dev/sda1 /media/rootdrive

  • Copy the contents of the SD card to the SSD:

    sudo rsync -avx / /media/rootdrive

Change boot option

  • Add the text root=/dev/sda1 to /boot/cmdline.txt. Be sure to not add carriage returns or line feeds!

    sudo nano /boot/cmdline.txt

After the next reboot the RPi won't run without the SSD until you remove "root=/dev/sda1" from cmdline.txt on the SD card.

So reboot and enjoy the speed at which the RPi now runs :)


You're leaving out an important detail: what kind of computer are you using to insert the SD into? Linux can read the RPI filesystem just fine, so if you're getting that error on a linux box, then the SD card is broken. No surprise to get that error on a Windows/Mac unless you have special software to read ext2/3/4 filesystems.

How are you checking if the pi "shows up on the network"? Is the PI connected using an ethernet cable? Do you have an external monitor you can plug in? That would tell you exactly how the boot process is going.

An external monitor, keyboard and mouse is pretty much a requirement for setting up a new Pi, until you have a few images ready to go.

  • The file system of the boot partition is vfat by default. He should not have any issues placing a file ssh there on MacOSX nor Windows. Access to the root partition is not needed.
    – FelixJN
    Jan 14, 2021 at 12:11
  • Well, yeah, but the second partition would have an error. It's possible that the SD card is just bad .. but the authoritative way to determine would be to boot the RPi with a monitor to see what's going on. Jan 14, 2021 at 21:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.