2

I recently installed an AudioIQ DAC+ device on my RPi3b+ running buster.

Following the directions in the user guide, I was able to get to the point that the drivers are loaded and appear to run, but no sound is emitted.

I'm wondering if I need to do something to force analog output to the headphone out port that isn't covered in the manual?

Here are some useless details. I would have put in also what's in alsamixer, but that doesn't translate well here.

What else should I check?

❯ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: IQaudIODAC [IQaudIODAC], device 0: IQaudIO DAC HiFi pcm512x-hifi-0 [IQaudIO DAC HiFi pcm512x-hifi-0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
❯ cat /proc/asound/card0/pcm0p/info
card: 0
device: 0
subdevice: 0
stream: PLAYBACK
id: IQaudIO DAC HiFi pcm512x-hifi-0
name: IQaudIO DAC HiFi pcm512x-hifi-0
subname: subdevice #0
class: 0
subclass: 0
subdevices_count: 1
subdevices_avail: 1
❯ aplay bachfugue.wav
Playing WAVE 'bachfugue.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Stereo
^CAborted by signal Interrupt...
~
❯ mplayer bachfugue.wav
MPlayer 1.3.0 (Debian), built with gcc-8 (C) 2000-2016 MPlayer Team
do_connect: could not connect to socket
connect: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing bachfugue.wav.
libavformat version 58.20.100 (external)
Audio only file format detected.
Load subtitles in ./
==========================================================================
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 48000 Hz, 2 ch, s16le, 1536.0 kbit/100.00% (ratio: 192000->192000)
Selected audio codec: [pcm] afm: pcm (Uncompressed PCM)
==========================================================================
AO: [pulse] Init failed: Connection refused
Failed to initialize audio driver 'pulse'
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:   1.5 (01.5) of 39.0 (39.0)  0.1%

Exiting... (Quit)

Update: Using the test image works and proves the hardware at least is not broken.

1

Are you sure you are still using ALSA only? The Pi OS has recently switched to PulseAudio, so if you're using an up-to-date system you may want to poke around Pulse settings.

Checking the kernel log (sudo dmesg) and the list of loaded modules (lsmod) might also help. Personally I would start by unloading the driver sudo rmmod <driver-name>, loading it back with sudo modprobe <driver-name> and then checking the kernel log for new messages. Or you could dump the whole log since boot and search for lines containing DAC, HiFi or the driver name.

Finally, I would take a look at the hardware. Your board appears to have a MUTE signal which should toggle when you plug the headphones in. Is that the case? I would also try connecting different headphones and RCA devices (amplifiers or TVs) to make absolutely sure you didn't miss the sound because of a connectivity problem.

BTW, what did you see in alsamixer? Your DAC card should have a volume bar next to it, which should not be empty or marked with an MM (that means "Mute"). Check out this screenshot if you don't see what I'm talking about.

1
  • Thanks Dmitry - yes, the alsamixer shows the device along with all the volume bars which are not muted. I did try both outputs with the same result (e.g. none). There are no PulseAudio messages in the log or lsmod. The driver is being loaded correctly in the logs. This reminds me of installing my soundblaster in 1995. :( – PaulProgrammer Jan 20 at 16:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.