I have installed openelec on the Pi, and I'm using an external hardrive (western digital 1tb elements, ac powered). It automatically mounts on boot. It plays all my standard movies perfectly, but when it comes to my blueray and hd movies (over 1.5gb), it starts to buffer every few minutes - which makes it impossible to watch.

Is this due to XMBC buffer cache? sorry I'm not really familiar with media centres and how they work, I'm setting it up for my kids.

Any help would be appreciated.

  • I'm having buffering issues as well except the file size doesn't matter. I've tried copying some 350mb TV episodes to my USB thumb drive (16GB SanDisk drive) and it still konks out within a short period of time. I changed the audio to Analog output but it only makes it less unstable instead of fixing it. I also have a keyboard plugged in to control it at the moment. Right now the Pi as my HDMI media player is mostly useless. Commented Feb 19, 2014 at 3:29
  • What build of Openlec? What file format?, have you tried 1 file on the sd card? Plays2gb mkv files from 2TB drive without this issue.
    – Mapperz
    Commented Apr 4, 2014 at 16:32

1 Answer 1


It could be a buffer issue or just an incompatible hard drive issue. XBMC buffers videos into RAM and plays from it (cache). This can be a problem in Raspberry Pi which has low RAM. This is explained here.

So play with different buffermode, cachemembuffersize, and readbufferfactor values in your advancedsettings.xml. I cannot give you the perfect combination that will work but either disabling cache/buffering or buffering in your SD card instead of your RAM (limited availability) might help. Note that if you cache in your SD card, it increases writes and may decrease its life.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.