1

I've just tried to update my raspberry pi 4 and am getting the error:

Unmet dependencies: libraspberrypi0 : Depends: raspberrypi-bootloader ( = 1.20210108) but 1.20201022 is installed

Running the suggested apt --fix-broken install command also fails.

I also get the above error about the bootloader when trying to install any other packages.

This image shows both commands being run and the errors they produce. (Apologies for it not being a screenshot. I literally can't install a package to take a screenshot because of this error):

I've highlighted the parts I've mentioned above Any suggestions? I've tried everything I can find online and I'm a bit of a Linux noob so I have no idea what else to try terminal

Edit

mount | grep boot output:

/dev/mmcblk0p6 on /boot type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,errors=remount-ro)

Edit 2

dmesg snippet

[    4.619097] brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43455-sdio.raspberrypi,4-model-b.txt failed with error -2
[    4.858933] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[    4.876959] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4345/6 wl0: Mar 23 2020 02:19:54 version 7.45.206 (r725000 CY) FWID 01-88ee44ea

14
  • I can only see a very fuzzy picture. Can't make out what it says. Please upload something with a higher resolution – Dirk Jan 15 at 17:55
  • @Dirk should be fixed now, apparently, the stackexchange android app really doesn't like images – Jack Jan 15 at 17:59
  • At a glance it looks like the boot partition is mounted read-only, which fouls up that update. – goldilocks Jan 15 at 18:32
  • @goldilocks Can I do anything about that? – Jack Jan 15 at 18:33
  • Try sudo mount -o remount,rw /boot. If that doesn't work, edit the output from mount | grep boot into the question. – goldilocks Jan 15 at 18:51
2
+25

You likely have a filesystem error on your /boot filesystem, and the errors=remount-ro option in your fstab makes it read-only when you try to write on it.

Confirm by running mount after the failed install command and checking the effective mount option for /boot. If it's indeed read-only, unmount it and try to fix the errors with dosfsck or by plugging the SD card in a Windows computer and scanning the disk there.

1
  • 1
    I ran mount and it does indeed show /boot as read-only. I've removed the sd card and run chkdsk on all volumes that showed up, it found no problems on any of them – Jack Jan 20 at 17:05
1

In the end, I just booted the Pi into recovery mode and re-installed Raspbian from NOOBs and that fixed whatever the issue was.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.