0

I want to save images from Bird-Table cam to a network drive but struggling to mount and connect.

So far I have:-

created /home/pi/TableCam

created /home/pi/TableCam/share (not sure why tho!)

edited FSTAB and added:-

//192.168.1.156/Pictures /home/pi/TableCam cifs guest 0 0

When my python runs camera.capture('/home/pi/TableCam/image.jpg') it saves in local drive but not on network drive.

However, when I SSH in and run "SUDO MOUNT /home/pi/TableCam" it successfully mounts and python works.

I'm guessing its a permission thing in FSTAB but don't understand enough about it.

Appreciate any help with this. Thanks!

2

I am not completely clear on your question, but it seems that your problem may be in your /etc/fstab file. We'll try that first, and if you can give some feedback as we go through this, perhaps we can solve it.

Let's first try changing your fstab entry to this:

//192.168.1.156/Pictures /home/pi/TableCam cifs rw,username=xxxxxx,password=yyyyyy,nofail,vers=1.0 0 0

You will need to substitute your username & password. If you don't have a username & password for your fileserver at 192.168.1.156 you'll need to share some details with us on that: how you control access to it, is it Samba or NFS, or ...?

Assuming you're able to supply a username & password in your fstab entry, run this command from the terminal (or SSH):

$ sudo mount -av 

Hopefully, this will show something like the following:

/home/pi/TableCam     : successfully mounted

If it doesn't, you'll need to provide the additional information I mentioned above, and the results of this command:

$ lsblk --fs
8
  • Target is RPI running Kodi on LibreELEC with a 1TB drive. Uses Samba for access. I used the command above and added root login credentials. ran [sudo mount -av] error reported:- pi@raspberrypi:~ $ sudo mount -av /proc : already mounted /boot : already mounted / : ignored mount.cifs kernel mount options: ip=192.168.1.156,unc=\\192.168.1.156\Pictures,vers=1.0,user=root,pass=******** mount error(95): Operation not supported Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) – Spezzer Jan 17 at 13:42
  • eeek - sorry about formatting – Spezzer Jan 17 at 13:45
  • I'm now wondering if I need to include the Workgroup (LIBREHD) Name in the MOUNT instruction? – Spezzer Jan 17 at 14:22
  • Working with your command line it seems to be having problems with "vers=1.0" and runs without it. I can't see what the problem with the syntax is tho. I still have the same issue. The camera.capture doesnt run on startup but does after running [sudo mount -av]. – Spezzer Jan 17 at 14:50
  • Thinking about this (which is a first!) if the mount was working successfully from fstab on boot then running [sudo mount -av] shouldn't work should it if already mounted? – Spezzer Jan 17 at 14:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.