1

I have been trying to setup a raspberry pi 0w to connect to my access point but I can't get it to connect. The first thing I did was to enable USB ethernet and make the ssh file so I can connect to it over SSH, I then used raspi-config to setup WiFi. After this, the RPi didn't have an IP under wlan0 as I expected. I then tried to use a wpa-supplicant file with my wifi password and SSID:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=GB

network={
 ssid="SSID"
 psk="pass"
 key_mgmt=WPA-PSK 
}

This didn't work after a reboot and using ifdown wlan0 && ifup wlan0 didn't work either. I then removed the usb ethernet config changes on the SD card but still had no luck. After adding them back in and then changing the indentation to 0 spaces, 4 spaces, 1 space and a tab it still didn't work. I honestly I have no idea what I'm doing wrong.

  • SSID is correct
  • Country is correct
  • Password is correct
  • Band is correct (2.4GHz)
  • Line endings are correct

After reading this post: Raspi doesn't connect with wifi anymore. What am I doing wrong?

I followed the steps to manually start wpa_supplicant (sudo wpa_supplicant -c /etc/wpa_supplicant/wpa_supplicant.conf -i wlan0) and all I am getting is a status_code 16 error 4 times then an auth_faliures=1 error. I know for certain the password is correct. I really have no idea what to do next.

4
  • To exclude the obvious: Does GB match your country? Does wpa_cli -i wlan0 scan (wait a few seconds then) wpa_cli -i wlan0 scan_results show networks?
    – FelixJN
    Jan 18 at 14:35
  • GB matches my country and I remember doing a scan with ifup (I think?) which definitely showed all the networks including the one I want to connect to.
    – Toffee
    Jan 18 at 15:10
  • This question is lacking any detail. You mention "enable USB ethernet" without detail and used obsolete commands "ifdown wlan0 && ifup wlan0" . There is no evidence - the bare minimum in ip a; ip r.
    – Milliways
    Jun 20 at 7:21
0

You probably need to add key_mgmt if you're using WPA:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=GB

network={
    ssid="SSID"
    psk="pass"
    key_mgmt=WPA-PSK 
}
1
  • 1
    I forgot to mention that I've already tried that. No luck.
    – Toffee
    Jan 18 at 14:12
0

Raspberry Pi cannot connect to some Wi-Fi routers.

It's a fact.

For example, my Raspberry Pi 3B and 3B+ cannot connect to my Linksys WAG200G although:

  • These Rpi can connect to all other Wi-Fi I have (2 smartphone access points, main ISP router, friend routers), and,
  • All other Wi-Fi enabled devices I have (2 smartphones, 2 company laptops, Nintendo Switch, Sony PlayStation 3, Pioneer Blu-ray player, iPad 3, all friend smartphones, etc.) can connect to the Linksys WAG200G.

I had to plug RPi to WAG200G with an Ethernet cable.

Try to access some other WIFI (smartphone access point, anything) to see if your problem is only with a specific router, like me.

2
  • This is very weird. My rpi 3 can connect to the WiFi just fine, and I have tried multiple WiFi routers.
    – Toffee
    Jan 21 at 14:05
  • Do you have a 3B or a 3B+? You can use the pinout command to know. I have researched info and it seems that Zero W and 3B models use the same BCM43438 chip for WiFi, while 3B+ model uses a CYW43455. I am not sure and I don't know the specs of these, but it is what I found online.
    – jesus2099
    Jan 22 at 13:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.