0

I am using ADS1015 with my RPi4, a couple weeks ago there were no probem with the i2c module,(the components were not connected, when not used) but since last week it is not detecting my device. I tried many things including ordering a new ADS(also not detected) many different cables, and also many solutions found on this forum. What could be my issue?

Wiring: https://imgur.com/a/STOSVMT https://imgur.com/a/uTjhOby

Device End: https://imgur.com/a/uldEhyq sudo i2cdetect -y 1: https://imgur.com/a/SBZ4uWq

/boot/config.txt: https://imgur.com/a/R2C7fZn

/etc/modules:https://imgur.com/a/XZrjUlo

lsmod: https://imgur.com/a/TGzPgsA

Already tried : i2c not detecting any connections Raspberry Pi 3 not detecting i2c device https://stackoverflow.com/questions/42904712/i2c-not-detecting-issues-in-hardware-or-any-other

3
  • i also tried if i killed my gpios: raspberrypi.org/forums/viewtopic.php?t=180505
    – shujaandi
    Jan 18, 2021 at 17:18
  • Please any terminal output as text to your Question.
    – Dirk
    Jan 18, 2021 at 18:10
  • when i try to run some code which needs input from my ADC i get:TimeoutError: [Errno 110] Conncetion timed out
    – shujaandi
    Jan 19, 2021 at 17:03

1 Answer 1

0

It's important to clearly show the connections made to devices so we can clearly see which Pi Pin is connected to which device pin.

In this case the problem appears to be at the device end. The wires are not connected to the device pins. The header pins may be through the through-hole plating - it does not mean they are connected. You need to solder the header pins to the device.

12
  • i havent soldered before and i used the same setup for nearly 2 months. could it happen that for 2 months the device was "accidentally" connected?
    – shujaandi
    Jan 18, 2021 at 17:31
  • It has happened, little point arguing about it.
    – joan
    Jan 18, 2021 at 17:33
  • well i soldered, and it was not the issue it is still not able to detect. i also uploaded an other angle of the pin layout, maybe you can see it better now
    – shujaandi
    Jan 19, 2021 at 17:11
  • The problem was at the device end. That's the end we need to see.
    – joan
    Jan 19, 2021 at 17:46
  • Unfortunately those connections look fine at both ends now.
    – joan
    Jan 19, 2021 at 18:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.