0

I got IPv6 with dnsmasq runnig on my raspberry to serve mobiles and other wifi devices. The raspberry pi is connected via eth0. The wlan0 device serves IPv6 addresses but the connected devices can't reach the internet. From what I can see from the log from dnsmasq resolving ip addresses works, but no internet connection. What do I need to do that they can connnect to the internet. Here is my conf:

cat dnsmasq.conf

domain-needed
bogus-priv
dhcp-authoritative
no-resolv
server=fd00::aaaa:bbbb:cccc:dddd
except-interface=eth0
interface=wlan0
bind-interfaces
domain=mywlan
dhcp-fqdn
enable-ra
dhcp-range=2002:aaaa:bbbb:cc:0:0:0:500,2002:aaaa:bbbb:cc:FFFF:FFFF:FFFF:FFFF, ra-names, 150
dhcp-option=option6:dns-server,[fe80::xxxx:yyyy:zzzz:aaaa]
dhcp-mac=set:client_is_a_pi,B8:27:EB:*:*:*
dhcp-reply-delay=tag:client_is_a_pi,2

cat dhcpcd.conf

interface eth0
        static 192.168.1.1
        ipv4
        ipv6
        dhcp
        dhcp6
        # enable routing solicitation get the
        ipv6rs
        # default IPv6 route
        # request an IPv6 address
        # request a PD and assign it to enp1s0u1u2
        ia_na 1 eth0
        ia_pd 1/::/64 wlan0/0/64



interface wlan0
    static ip_address=192.168.2.1/24
    nohook wpa_supplicant
2
  • what's your question? – jsotola Jan 19 at 9:16
  • @jsotola The devices can't reach the internet, how can I solve that? – Marc Jan 19 at 11:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.