1

If I do 'apt update' or any other apt command, the terminal screen is cleared and

ist9DepRemovEEN8pkgCache11DepIteratorE, version APTPKG_5.0

is printed. I've tried to reinstall apt using wget

 wget http://mirrordirector.raspbian.org/raspbian/pool/main/a/apt/apt_1.8.2.2_armhf.deb

and it seems to be successful, but there's no change :-(

5
  • wget just downloads a package. Install .deb-packages via dpkg -i package.deb. However maybe try apt install --fix-broken first. – FelixJN Jan 19 at 13:40
  • thanks @Fiximan ! Sorry I should have said I then did dpkg -i apt_1.8.2.2_armhf.deb and it went through all the updating triggers etc, but the net result is the same. Doing apt install --fix-broken just gives the same result - a flicker then a screen clear then it says ist9DepRemovEEN8pkgCache11DepIteratorE, version APTPKG_5.0 – daneee Jan 19 at 13:55
  • wahoooo - reinstalling libapt-pkg5.0_1.8.2.2_armhf.deb did the trick!! I think it got corrupted by node-red when I was adding to the pallet... THANK YOU – daneee Jan 19 at 14:06
  • 1
    Nice to hear. Please make your solution an answer, so others may profit of it. – FelixJN Jan 19 at 14:16
  • apparently I can accept my answer in two days. Good old stackexchange! Lol – daneee Jan 19 at 19:45
5

reinstalling libapt-pkg5.0_1.8.2.2_armhf.deb did the trick!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.