1

Using RPi 4B, image 2020-08-20-raspios-buster-armhf-lite.img with kernel 5.4.51-v7l+, but tried also to use Ubuntu Server with custom compiled kernel 5.4.83.

I have trouble getting UARTs working with DMA for Raspberry PI4. There is kernel DMA initialization error seen in dmesg and if I understand correctly, UARTs is working without DMA.

I need to run UARTs at high speed (4M baud), so DMA is needed otherwise data is lost.

This is what I'm getting in dmesg when opening UART port (eg. by minicom):

[   65.809485] uart-pl011 fe201400.serial: no DMA platform data
[   72.853570] uart-pl011 fe201600.serial: no DMA platform data

I added following lines at config.txt end - I need to use custom clock to support 4MBPS and UARTs 0,2,3,5.

init_uart_clock=64000000
dtoverlay=disable-bt
enable_uart=1
dtoverlay=uart2
dtoverlay=uart3
dtoverlay=uart5 

Question: How to get all UARTs working with DMA for RPi 4b?

Edit: Tried also with older kernel 5.2.21-v7l+ , same result

3
  • is this relevant to your question? Jan 26, 2021 at 12:22
  • No, this says about RPI3 and older, which used BCM2835. RPi 4 is using BCM2711 which have DMA for UARTs (at least as stated in documentation)
    – Mazi
    Jan 26, 2021 at 15:00
  • No worries, I missed that point in that link :p Jan 26, 2021 at 22:31

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.