1

I know, there are already several questions about this, but none of them helped me. I have a rasbian installation and try to connect to my bluetooth headset.

When I run sudo bluetoothctl I can find the headset, I can pair it and I can trust it, but trying to connect I get an error:

$connect XX:XX:XX:XX:XX:21
Attempting to connect to XX:XX:XX:XX:XX:21
Failed to connect: org.bluez.Error.Failed

In the syslog (sudo cat /var/log/syslog | grep -i protocol) I see:

....
Jan 26 22:24:29 raspberrypi bluetoothd[363]: a2dp-sink profile connect failed for XX:XX:XX:XX:XX:21: Protocol not available
Jan 26 22:24:51 raspberrypi pulseaudio[1007]: Failed to load module "module-native-protocol-unix" (argument: ""): initialization failed.
Jan 26 22:24:53 raspberrypi bluetoothd[363]: a2dp-sink profile connect failed for XX:XX:XX:XX:XX:21: Protocol not available
Jan 26 22:24:55 raspberrypi bluetoothd[363]: a2dp-sink profile connect failed for XX:XX:XX:XX:XX:21: Protocol not available
Jan 26 22:24:56 raspberrypi bluetoothd[363]: a2dp-sink profile connect failed for XX:XX:XX:XX:XX:21: Protocol not available
Jan 26 22:26:07 raspberrypi bluetoothd[363]: a2dp-sink profile connect failed for XX:XX:XX:XX:XX:21: Protocol not available
Jan 26 22:26:20 raspberrypi bluetoothd[363]: a2dp-sink profile connect failed for XX:XX:XX:XX:XX:21: Protocol not available
Jan 26 22:26:21 raspberrypi bluetoothd[363]: a2dp-sink profile connect failed for XX:XX:XX:XX:XX:21: Protocol not available
Jan 26 22:26:21 raspberrypi bluetoothd[363]: a2dp-sink profile connect failed for XX:XX:XX:XX:XX:21: Protocol not available
Jan 26 22:26:23 raspberrypi bluetoothd[363]: a2dp-sink profile connect failed for XX:XX:XX:XX:XX:21: Protocol not available
Jan 26 22:32:30 raspberrypi bluetoothd[363]: a2dp-sink profile connect failed for XX:XX:XX:XX:XX:21: Protocol not available
Jan 26 22:35:00 raspberrypi bluetoothd[1497]: a2dp-sink profile connect failed for XX:XX:XX:XX:XX:21: Protocol not available
Jan 26 22:39:25 raspberrypi bluetoothd[1497]: a2dp-sink profile connect failed for XX:XX:XX:XX:XX:21: Protocol not available

I already tried a couple of suggested solutions, like reinstalling pulseaudio-module-bluetooth (https://askubuntu.com/a/1228816) or module loading (https://raspberrypi.stackexchange.com/a/67665 which is based on this: https://askubuntu.com/a/689297).

I still can't load the module-bluetooth-discover:

$sudo pactl load-module module-bluetooth-discover
Connection failure: Connection refused
pa_context_connect() failed: Connection refused

Any ideas?

2
  • Is there any reason you aren't just using the Bluetooth widget on the Menu bar?
    – Milliways
    Jan 26, 2021 at 23:17
  • Yes. I have no gui and I even don't have a screen. I just connecting to my device by ssh.
    – bernhardh
    Jan 27, 2021 at 9:35

1 Answer 1

2

If you are using the Lite RPi OS (or maybe even the "medium" one), you should know that there are substantial differences in the level of Bluetooth support.

Depending upon which of the three distro versions you've installed, setting up your Bluetooth headset can be quite simple (as in Milliways comment), or it can be a complete nutroll - as documented in this "answer".

Hope that helps... in other words, this can be straightforward, or it can be difficult, depending on which distro you've installed.

EDIT, 20210127: I've learned of another "How-To Guide" for using Bluetooth on the Lite version of RPi OS. I've not tried it myself, but like mine, it also looks to be in the nutroll class of solutions; any feedback is welcomed.

3
  • I am using Raspbian GNU/Linux 10 (buster) without a gui (I use it as an audio box für my child) and since I invested already about 5 hours with it, it looks like we are at a nutroll level ;)
    – bernhardh
    Jan 27, 2021 at 9:38
  • You have my sympathy. The "answer" I referenced above was done to get a Bluetooth speaker working. I imagine that getting headphones to work is mostly the same. If so, this will likely be of some help. It's been a while since I worked through that, but feel free to ask questions if you get stuck. And - feel free to add your edits to the nutroll.
    – Seamus
    Jan 27, 2021 at 10:06
  • @bernhardh: One other thing that might help: At the bottom of the Comment section to my QUESTION there are links to a chatroom session between myself & ukBaz (who was hugely helpful). I don't know that they'll be useful, but feel free to peruse those also.
    – Seamus
    Jan 27, 2021 at 10:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.