-2

I'm trying to use the flask_ask library however I for some reason can't get it to work. Whenever I try to reinstall flask-ask by doing pip install flask-ask I am given the same thing below so I think I have it installed.

 Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: flask-ask in ./.local/lib/python2.7/site-packages (0.9.8)
Requirement already satisfied: Flask==0.12.1 in ./.local/lib/python2.7/site-packages (from flask-ask) (0.12.1)
Requirement already satisfied: aniso8601==1.2.0 in ./.local/lib/python2.7/site-packages (from flask-ask) (1.2.0)
Requirement already satisfied: pyOpenSSL==17.0.0 in ./.local/lib/python2.7/site-packages (from flask-ask) (17.0.0)
Requirement already satisfied: six==1.11.0 in ./.local/lib/python2.7/site-packages (from flask-ask) (1.11.0)
Requirement already satisfied: PyYAML==3.12 in ./.local/lib/python2.7/site-packages (from flask-ask) (3.12)
Requirement already satisfied: click>=2.0 in /usr/lib/python2.7/dist-packages (from Flask==0.12.1->flask-ask) (7.0)
Requirement already satisfied: Werkzeug>=0.7 in /usr/lib/python2.7/dist-packages (from Flask==0.12.1->flask-ask) (0.14.1)
Requirement already satisfied: Jinja2>=2.4 in /usr/lib/python2.7/dist-packages (from Flask==0.12.1->flask-ask) (2.10)
Requirement already satisfied: itsdangerous>=0.21 in /usr/lib/python2.7/dist-packages (from Flask==0.12.1->flask-ask) (0.24)
Requirement already satisfied: python-dateutil in ./.local/lib/python2.7/site-packages (from aniso8601==1.2.0->flask-ask) (2.8.1)
Requirement already satisfied: cryptography>=1.7 in /usr/lib/python2.7/dist-packages (from pyOpenSSL==17.0.0->flask-ask) (2.6.1)

Then when I go back to try to run it in Python 3.7.3 it simply says that the flask-ask library doesn't exist. enter image description here

1
2

You're using python 3 but installed the module for python 2

Use sudo pip3 install flask-ask to install it for python 3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.