1

I am trying to get my Pi 4 setup with Ubuntu 20.10 server using WIFI. I have setup the WIFI correctly at the time of creating the image. I know this because I have a RBI 3B+ that I have done the same exact thing with and it works perfectly. Both Pis are booting via USB SSD.

The first issue I am having is that power management is always enabled on wlan0. I can disable it manually by running "sudo iw wlan0 set power_save off". If there is any way to permanently turn off the power_save on wlan0, I have not found one.

The second issue I have is, once power_save is set to off, I cannot get the wlan0 interface to come up. I have tried "sudo ip link set wlan0 up" but that does not appear to do anything as when I check the status of wlan0 it state is still DOWN.

I know it is not a hardware failure because I can stick a SD card with Raspberry Pi OS in and connect via WIFI.

This is the 50-cloud.init.yaml file that I am using:

network:
    ethernets:
        eth0:
            dhcp4: yes
            match:
                driver: bcmgenet smsc95xx lan78xx
            optional: true
            set-name: eth0
    version: 2
    renderer: networkd
    wifis:
      wlan0:
        access-points:
          {SSID}:
            password: {pw}
        dhcp4: true
        optional: true

When is apply the netplan using the -debug flag I only get a warning with the status of power_save on wlan01 regardless if it on or off.

Thanks for the help.

3
  • Perhaps you ask at the wrong place. This is not a raspi question, it's rather a ubuntu one, I think ;-). askubuntu.com/questions/85214/… Even if the link doesn't answer your question. IMHO there you'll get better answers. Look at the last answer, it's the newest. I have no ubuntu server running, so I can not say if anyting of that is applicable for 20.10. Jan 27, 2021 at 17:54
  • 1
    Nothing on that page helps me. This is a Pi issue for sure. In my question I noted that I have no issues with the same configuration on my RPi 3B+. Both Pis are running Ubuntu 20.10 and the config is identical. There is deftly something up with the power management on the RP 4. I can bring wlan0 out of power management but will never stay off not matter what I have tired.
    – Jeremy
    Jan 28, 2021 at 5:55
  • I did not try to convince you that it is a Ubuntu question. I just gave you a tipp. I think it would be better to ask on SO ubuntu. It seems to be a configuration issue. Many people here (including me) have good knowledge about Raspian, but not so much with Ubuntu. I also mentioned that the linked page hardly could help you, but that's the place where you should ask. Jan 28, 2021 at 10:08

1 Answer 1

1

Depending on what tools you have in Ubuntu, you can try the following

For NetworkManager, edit /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

[connection]
wifi.powersave = 2

For TLP, edit /etc/default/tlp

WIFI_PWR_ON_AC=off
WIFI_PWR_ON_BAT=off

Regarding your second issue, you should check the kernel log after trying to bring the interface up. Chances are, there are error messages in it explaining what's wrong. Loading brcmfmac with debug parameter set to 2 or 3 could get you more messages:

modprobe brcmfmac debug=3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.