recently i bought a raspberry pi 3 B+ but i can't connect to the internet through the wifi. I already read lots o similar problem on the internet but any of the suggested solutions worked form me. Since I'm very new to the world of raspberry I'd like to know what am I missing.

the problem is that when I boot my raspberry i got "wireless interface not found".

  • If I run "ifconfig" or "ifconfig -a" I only got eth0 and lo, no wlan0
  • If I run "sudo iwlist wlan0 scan" I got "wlan0 Interface doesn't support scanning."

If I run cat /etc/os-release this is what I got

PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"
VERSION="10 (buster)"

Wpa_supplicant file configuration

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev


If I run "sudo raspi-config" under "localisation options" if I press "Wlan Country" I got this error "no wireless interface found" and then "There was an error running option L4 WLAN Country "

Any ideas? I don't know what to do, thanks


1 Answer 1


You can try what you want, as long as you don't see the WiFi interface wlan0 on an unmodified Raspberry Pi installation, nothing will work. It could be that your WiFi is simply broken. To verify this flash a fresh Raspberry Pi OS lite and boot it. Then you must see the WiFi interface wlan0, e.g. with

rpi ~$ ip -br link

no matter if UP or DOWN. If you don't see it then it is very likely that you have a problem with your hardware. I see no way to repair it. Just purchase a USB/WiFi dongle and you can still use your RasPi. That dongles are not very expensive.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.