0

I'm looking to install a great DS emulator on a raspberry pi4. It's called MelonDS and it is available for Linux. I attempted to install on the 64bit ubuntu image. This is what I tried.

 sudo snap install melonds
error: snap "melonds" is not available on stable for this architecture (arm64)
       but exists on other architectures (amd64).

I'm not sure where to go from here. Please help if you can. This project is intended to add melonDS to RetroPie. But we need to confirm it works. https://retropie.org.uk/forum/topic/28949/need-help-with-writing-install-script/4?_=1612018494282

Edit:

MelonDS has a version available for 64 arm devices. http://melonds.kuribo64.net/downloads.php If you want to test out this emulator yourself please not it requires BIOS files.

4
  • it's telling you that melonds is only available on amd64 architecture (e.g. intel, amd cpus), not arm64 (e.g. ARM cpus) – Jaromanda X Jan 31 at 0:13
  • @JaromandaX Is there any other way to install it? – UNKNOWN Jan 31 at 15:22
  • "it requires BIOS files" - so there's no legal way to test the software, except for buying a DS, cracking it and dumping the BIOS? – Dmitry Grigoryev Feb 9 at 9:55
  • Yes that is the only way to do it legally – UNKNOWN Feb 10 at 0:44
1
+50

There are instructions on how to install build MelonDS from source in the creator's GitHub page: github.com/Arisotura/melonDS

1
  • I’m a little stuck on those instructions, can you tell me how to start it after compiling? Do I have to move some files around? – UNKNOWN Feb 10 at 12:48
2

A program must be compiled for the processor it is running on. All Raspberry Pis have an ARM processor. The installation procedure tells you that it isn't available for this architecture (arm64) but only for intel/amd processors (amd64). So melonDS cannot run on Raspberry Pis. You may think to run it as virtual machine on a virtual manager, but that is completely unusable because of the reduced performance of a RasPi and lack of vm hardware support. The only way I see to make it availabe is to compile melonDS from its sources on a Raspberry Pi or cross compile it on another computer for the ARM architecture.

4
  • Sorry for not saying it is available for arm devices. Please follow my new link. – UNKNOWN Feb 1 at 0:51
  • @UNKNOWN Then use that version and your problem should be solved, isn't it? – Ingo Feb 1 at 10:46
  • The problems there is no instructions to install for this version. Only where to place bios files and operation information is provided. – UNKNOWN Feb 2 at 21:41
  • MelonDS is available for arm CPUs – manarinian Feb 15 at 13:17
0

MelonDS isn't available for the Raspberry Pi then, but you can use DeSmuMe, a close alternative. It's very slow though, because the Raspberry Pi has a limited amount of RAM, and DeSmuMe uses a LOAD of that.

Install it using:

sudo apt install desmume

I wouldn't install it DIRECTLY onto the Pi, though. You can use RetroPie, but this is unstable. There's a script under the experimental tab on the installer, you can install it from there.

5
  • Yeah I’ve desmume. Did you not read about the version for arm above? – UNKNOWN Feb 10 at 1:35
  • @UNKNOWN Yes, but you just said it can't run without BIOS files, one person said the only way to get BIOS files is buying a DS, dumping the BIOS with cracking, and transferring it to your Pi, which is impossible and the person above just said MelonDS is completely unavailable for Pis. – Amint Feb 10 at 12:23
  • Actually it is not impossible you don’t even need to crack it. There is a game chip made by hackers that can allow micro SD card access. The software to dump bios can be loaded to that. – UNKNOWN Feb 10 at 12:45
  • Oh, that actually makes sense. But the pi only has one SD card slot, and that game chip could erase the entire card. Or can you just pick the folder? I don't even think the DS uses exFAT. The root partition is automatically that filesystem. The only accessible filesystem is FAT32. I know, that's what the boot partition is formatted to. – Amint Feb 10 at 12:53
  • no I mean the gamechip has an SD card slot in it – UNKNOWN Feb 10 at 23:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.