1

My Raspberry Pi works well, but seems to go into semi-hibernation after a while. I have it plugged in to a composite TV and keyboard; but I usually access it through ssh from another machine after logging in locally. Sometimes it becomes unreachable by ssh, and I turn on the TV -- no display. Typing at the keyboard doesn't awaken it, even with known commands like 'sudo reboot'. I end up pulling the plug and restarting. There is a cron job running every minute logging temperature, so I can tell that the system had been running fine right up to the hard reset -- it had just become unreachable.

There's a wifi adapter, but it's plugged in to a powered hub. Any thoughts?

  • Is the cron job using all of the processor and blocking other jobs and making the system seem unresponsive. As a test you could back off the cron job to once every 5 minutes and watch the output of the top command. – Steve Robillard Dec 3 '13 at 22:18
  • Good idea! I will do that and report back... – mcarlstroem Dec 4 '13 at 1:09
  • Also have a look in /var/log/syslog to see if anything else is weird during that time. – goldilocks Dec 4 '13 at 14:11
  • Changing the timing on the cron job didn't make a difference; but following goldilocks' suggestion I took a look at the syslog. There's much there that I don't understand -- but it seems like a USB device is causing the trouble. I now suspect that my wireless router is trying to cycle IP addresses and that the wifi adapter and the Pi get into a scuffle over what to do, and it consumes all available memory. I'll try a different wireless network and some config changes and report back. Thanks for your help! – mcarlstroem Dec 4 '13 at 18:05
  • In case anyone is interested in what didn't work so far, I have tried changing wireless networks; no luck. I also tried swapping out the USB hub, since the syslog seemed to find problems with a USB device; also no luck. I've yet to try a different wireless adapter, and I've yet to try a fancier power supply. Until I have the hardware, I'll try it without the wireless adapter next. Thanks all for your suggestions! – mcarlstroem Dec 9 '13 at 22:34
1

Are you using a cheap power adapter? This sounds a lot like an issue I had with mine in the beginning. It would work fine, and then stop responding to input. It wouldn't freeze entirely since any media that was playing would continue playing but it would not respond at all to keyboard or mouse input. It turns out that it wasn't getting enough power from my cheap phone charger. Buying a power supply from canakit.com resolved the issue for me, but any power supply intended for the Pi would probably work

  • Thanks for the suggestion. I have tried a couple, and the one I'm currently using is from a Palm Pre -- moderately high end. I might buy another just to test that theory. – mcarlstroem Dec 4 '13 at 19:39
-1

A new wireless adapter was the fix. Thanks for your suggestions!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.