I am trying to connect to Raspberry Pi pico using Thonny. I am using Ubuntu 20.04.

Giving Error

Couldn't find the device automatically. 
Check the connection (making sure the device is not in bootloader mode) or choose
"Configure interpreter" in the interpreter menu (bottom-right corner of the window)
to select specific port or another interpreter.

Tried to install firmware

In Tools>Options>Install or update firmware I pushed BOOTSEL button, but it is not changing anything.

enter image description here

  • 1
    Try with Raspberry Pi OS.
    – CoderMike
    Commented Feb 1, 2021 at 11:56
  • 1
    @CoderMike The pico is a dual-core Cortex-M0+; it can't run Raspberry Pi OS. Commented Feb 1, 2021 at 16:23
  • 1
    @ElliotAlderson in mean instead of Ubuntu on the Pi ! Maybe he's not using a Pi? What machine are you using to connect to the Pi Pico?
    – CoderMike
    Commented Feb 1, 2021 at 17:04
  • 1
    @CoderMike The Raspberry Pi Pico is closer to an Arduino than what we normally think of as a Raspberry Pi. It can't run any kind Linux. It has a bootloader and a small Python interpreter, typically. Commented Feb 1, 2021 at 17:30
  • 1
    @ElliotAlderson i know I've got 2 Pico's. I want to know what machine the OP is using to connect to the Pico, my assumption is he is using a Pi to connect to the Pi Pico.
    – CoderMike
    Commented Feb 1, 2021 at 17:34

7 Answers 7


Press and hold BOOTSEL button while you connecting it to USB of your computer. Release it after connected. Copy UF2 file to newly mounted PRI-PR2 storage. It will restart, ready to go. According to Getting Started:

  1. Download the MicroPython UF2 file...

  2. Push and hold the BOOTSEL button and plug your Pico into the USB port of your Raspberry Pi or other computer. Release the BOOTSEL
    button after your Pico is connected.

  3. It will mount as a Mass Storage Device called RPI-RP2.

  4. Drag and drop the MicroPython UF2 file onto the RPI-RP2 volume. Your Pico will reboot. You are now running MicroPython.

  • 1
    I was doing same thing using thonny. Thonny is installing latest firmware to pico. My problem was pico is disconnecting within seconds after pushing BOOTSEL. So I copied files within second. Now it is working fine. Thanks
    – PSKP
    Commented Feb 2, 2021 at 2:35
  • 1
    My problem was caused by my own stupidity. I seemed to be able to install the files from Thonny ("Done" announced) but unable to connect afterwards. Turns out I had a connection from the Serial app established earlier on which was re-connecting on each Pico re-boot. Hope this helps someone else! Keep safe, guys...
    – Jonathan
    Commented Feb 23, 2021 at 10:54

I tried the above steps, but my pico still won't run micropython.

It randomly disconnected itself, and when it reconnected, windows wasn't able to identify it, and thonny was giving the "couldn't find the device automatically" error. However when thonny was installing micropython, it said it couldn't find a port. Multiple USB cables were used, as well as connecting it to an actual raspberry pi. The rpi just claimed the device was busy, even when i hit the stop/restart button in thonny.

Edit: fixed by using the flash_nuke.uf2


For me it was a permission issue.

sudo usermod -a -G dialout <username>

Did the trick.

  • 1
    and that the bootloader option should not be held when placing the pico pi back in , and put the pi into the usb, * before* bringing thonny IDE up
    – Vass
    Commented Nov 27, 2022 at 0:13
  • This worked for me, but I had to reboot afterwards. Logging out and back in was not sufficient.
    – salsbury
    Commented Dec 14, 2022 at 6:55

Downloaded Thonny installed the program. Then tried to install micropython on the pi. In Thonny I had this error come up. " Downloading 563200 bytes from https://micropython.org/resources/firmware/rp2-pico-20210902-v1.17.uf2 Writing to D:\firmware 100% Waiting for the port... Warning: Could not find port in 10 seconds

Done! "

Tried putting the pi in boot mode and dropped in the flash nuke uf2. The pi resets after I drop it in like it is supposed to but Thonny still cant seem to do find the port.

  • It looks more like a comment Commented Jan 13, 2022 at 2:30

Just to give some more attention to Aiden L's answer: If your Pico really doesn't cooperate, try completely resetting it with flash_nuke.uf2 (file from adafruit.com). This was the only solution that worked for me.


I have noticed that when you try to install the Pico's firmware from Options->Interpreter it leads to that issue.

A possible solution which I have found is disconnect the Pico, press BOOTSEL connect it, and choose it from the bottom right corner. A firmware instillation window will appear, and it updates the Pico without any issues.


The flash_nuke worked for me. Right after I uploaded main.py and restarted it, lost all ability to communicate on Com4. No reinstalling drivers or removing them helped. Even tried reloading the micropython software.

  • 1
    That answer has already been given.
    – Chenmunka
    Commented Mar 12, 2023 at 21:40
  • Yup - I do find it helpful to confirm when something specific works when I read comments. With no score yet, I am not allow to reply, or upvote, or anything so this is the only way I could confirm. Thanks though Chenmunka. Commented Mar 13, 2023 at 22:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.