0

I have a Raspberry Pi 3, model B+. A few years ago, the wifi adapter started to fail (I sometimes had to reboot it, disconnect it, etc. to get it to work), and finally it eventually died. So a little while back, I bought a USB wifi adapter made by TP-Link (TP-Link TL-WN725N) and plugged it in. I'm was using Raspian and the wifi symbol in the GUI continued to be grayed out, but I was able to edit the wpa supplicant file and connect.

Now, for some reason, that doesn't work, and I've been trying to figure out why for a while but I'm rather new to these things and I'm not sure whether it's hardware problem, a problem with the adapter, the router, etc.

I plugged it in with ethernet. Here's what happens if I run ifconfig without the adapter:

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.134  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::cec2:69e3:f48e:a43f  prefixlen 64  scopeid 0x20<link>
        ether b8:27:eb:47:17:39  txqueuelen 1000  (Ethernet)
        RX packets 60  bytes 8258 (8.0 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 88  bytes 12805 (12.5 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 9  bytes 524 (524.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 9  bytes 524 (524.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

And then, when I plug in the adapter, it says this:

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.134  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::cec2:69e3:f48e:a43f  prefixlen 64  scopeid 0x20<link>
        ether b8:27:eb:47:17:39  txqueuelen 1000  (Ethernet)
        RX packets 139  bytes 14434 (14.0 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 180  bytes 27753 (27.1 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 9  bytes 524 (524.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 9  bytes 524 (524.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether f4:f2:6d:1c:3d:a9  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

The wpa_supplicant.conf file says this (ES because I live in Spain):

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=ES

network={
        ssid="NETWORK"
        psk="password"
}

The router has 2.4 GHz and 5 GHz bands.

Any suggestions as to how I can connect to the wifi or better identify where the problem is?

Thank you!

6
  • perhaps your access point 2.4GHz is disabled? By the way, the fact that the access point has 5GHz is irrelevant since the tp-link device only does 2.4GHz - if it worked, then stopped working, something has changed, either on the pi or on the router - only you know what you've changed to break the setup Feb 1 at 23:38
  • So, I've tried fresh installs, both of Raspbian and Ubuntu. I've also tried putting the SD card in my Pi 4 (it works there), but the Pi 3 continues with this problem. Moreover, in the GUI it says "No wireless interfaces found", so it's not just that it's not picking up my specific wifi, but rather that it's not picking up wifi in general. I checked the 2.4GHz access point, and it's on. I can see them both and connect to them via my phone and computer, but on the Pi nothing.
    – bzodonnell
    Feb 2 at 14:42
  • I take it you tried the tp-link wifi dongle in the pi Feb 3 at 5:48
  • is the TL-WN725N V1, V2 or V3? Seems you have to compile drivers for at least the V2 and V3 Feb 3 at 5:54
  • It's a V1, so I apparently don't have to install drivers (for Linux at least)
    – bzodonnell
    Feb 6 at 23:35
2

If you have a broken or weak WiFi on-board device on your RasPi it can still be that it disrupts the connection. You should completely disable it by setting this option in /boot/config.txt:

dtoverlay=disable-wifi

Also don't forget to

rpi ~$ rfkill unblock wlan

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.