0

I have an Access Point set up on my Raspberry Pi 4 using a wifi dongle and hostapd. Everything works great, but when I start to transfer a file over FTP, the connection aborts at around 1 GB and I have to reconnnect to the AP.

Is there a way to solve this problem?

2
  • Do you stay connected indefinitely if you're not using FTP? Feb 17, 2021 at 13:11
  • Yes I think so, I just noticed the problem when I transferred a large file via FTP. But I think it happens always, when I need big bandwidth and it looks like there is already a solution for that problem. Feb 17, 2021 at 14:55

1 Answer 1

2

I have seen similar behavior because of weak firmware. Not sure if it also helps in your case but it might be worth a try. You can downgrade the firmware to a more stable version. Have a look at Access point as WiFi router/repeater, optional with bridge. At the beginning there is a part, labeled IMPORTANT UPDATE on 2020-09-02, that described how to downgrade the firmware.

2
  • Thank you for your answer, it sounds hopeful. I will try it soon and tell you if it worked for me. Feb 8, 2021 at 17:01
  • I tried it. But the AP is still crashing on transferring large files. Is there a more stable version? Feb 22, 2021 at 20:42

Not the answer you're looking for? Browse other questions tagged or ask your own question.