had a power outage and, upon the return of electricity, my rPI (4.0) won't boot properly:

SETUP: SD card for /boot and /root

USB-C SSD for data, partitioned into 1 NTFS for samba, 1 EXT4 for other data

SSH access only (and I don't have a micro HDMI so I can't connect to a monitor to see any boot errors)

i've localized the issue to the fstab line which (attempts to) mount the SSD/EXT4 partition. if i comment it out, the pi boots properly. if i run fstab with the line, it hangs up and won't boot properly (i need to then manually edit the fstab file on the SD card on another machine to re comment-out the offending line)

I can re-mount the EXT4 partition manually and it works just fine. fstab entry is:

fstab entry: PARTUUID=BLAHBLAH-02 /mnt/cloud ext4 default 0 0

(BLAHBLAH-01 is the PARTUUID for the correctly-mounting NTFS partition)

possible issues:

  1. fdisk reports the ext mount as ID 7 | TYPE HPFS/NTFS/exFAT not EXT 4?
  2. blkid reports the correct partition ID, but lsblk does not (it omits the -01 and -02)?

any thoughts?

  • Here's a thought: "Why are you using an NTFS partition as your Samba share?
    – Seamus
    Feb 3, 2021 at 23:03

1 Answer 1


my fstab entry had the operator "default" when the correct syntax apparently is "defaults"

i changed that and it managed to boot up. so i think i solved it?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.