2

my setup is this:

  • Samsung LCD TV
  • Raspberry Pi model b rev 2
  • Logitec Harmony One Remote
  • Yamaha HTR-4065 AVR

and it have worked really well to controll openelec with the harmony remote (that was set to controll the TV). i recently bought the reciever and it continued to work great, but today the pi stopped recognizing the CEC-signals from the harmony remote. It does however recive the signals if i use the recievers remote. (but that's not a good solution for a bunch of reasons).

how can i make the raspberry pi recieve the cec signals from the tv through the reciever like it worked earlier?

3

I found a solution myself, pretty logical when i think about it...

If i disable CEC on the AVR, the TV-CEC signals are going through fine. I guess the cable cant send CEC-signals for multiple machines simultaneously.

The strange thing is that i can't remember ever changing that setting on the AVR (pretty sure it's been on all the time) even when it worked earlier.

Hope this can help if anyone finds themselves in a similar situation.

0

Oh. I have - sort of - the same setup here!

Well, I plugged th RPi into my TV (Samsung with CEC, I can control XBMC trough it). Set the TV to use an external source for the Audio and with an optical cable connected my Z-5500.

In my TV there's and option to turn CEC on/off and also when it is enabled there's a list of Devices it recognizes.

Try making sure your TV -> Pi commands are ok (test with another ROM). Then work your way there.

Hope I got something to offer, not needing a mouse/keyboard is great.

  • Thanks for your input, i actually tried this on to different SD-cards one with raspbmc and one with openelec, same result. found my solution myself lter as you can se above. – Volmar Dec 6 '13 at 19:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.